Project

General

Profile

Bug #3803

Plain-text email issues

Added by Sarah Morgano over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Email Notifications
Target version:
Start date:
2015-02-11
Due date:
% Done:

0%

Estimated time:

Description

Hi Ray,

Another member reported not being able to view the link to reset her password over the weekend. She said that she had to look at the source to get the URL and that the Commons should support text-only readers. Didn't the commit 0ecd992 fix this issue?

Best,

Sarah


Related issues

Related to CUNY Academic Commons - Bug #3781: Plain-text email formatting issuesResolved2015-02-02

History

#1 Updated by Raymond Hoh over 6 years ago

  • Target version set to 1.7.12

Apologies that the fix didn't work.

Looking into it.

#2 Updated by Raymond Hoh over 6 years ago

So the issue is the password reset link is wrapped around brackets.

eg. <http://example.com/wp-login.php?action=rp...>

This caused a conflict with our HTML to plain-text parser because the parser thinks that the password reset link is a HTML tag when it isn't. The parser removes invalid HTML tags as in the case of the password reset link.

I've fixed this (for real this time) in commit decb99e.

#3 Updated by Raymond Hoh over 6 years ago

  • Status changed from Assigned to Resolved

#4 Updated by Sarah Morgano over 6 years ago

Fantastic, thanks Ray!

#5 Updated by Matt Gold over 6 years ago

Thanks from me as well, Ray

Also available in: Atom PDF