Project

General

Profile

Bug #3948

Custom XML Sitemap Functionality Not Working

Added by Chris Caruso about 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2015-03-25
Due date:
% Done:

0%

Estimated time:

Description

Hi all,

Last year, all of the Program Social Media Fellows used the "Yoast WordPress SEO" plugin to create custom XML Site Maps for their sites, with the intention of prioritizing their top 4 or 6 most important sub-pages. However, none of these changes have made it into the Google results.

I've attached a screen grab of the results for a search on "philosophy graduate center". You can see in the first result that the Kentico page is configured to show sub pages like "Faculty," "Admissions," etc. but the Commons result below does not show any of the sub pages that have been identified in the XML site maps.

This is the case for philosophy.commons, as well as english. anthropology. urbaned. gcarthistory. gcmusic. gcees. hlbll.

Can you look into this for us? We think this could help us get better search engine visibility and more traffic if we could get it to work.

Thank you,

Chris

xml site maps.jpg (124 KB) xml site maps.jpg Chris Caruso, 2015-03-25 11:51 AM

History

#1 Updated by Boone Gorges about 4 years ago

  • Assignee set to Daniel Jones

Dan, could you see what you can find please? Thanks.

#2 Updated by Matt Gold about 4 years ago

And thank you for bringing this to our attention, Chris

#3 Updated by Daniel Jones about 4 years ago

Sure thing!

Chris - have you tried going into the Yoast SEO plugin XML Sitemap settings and clicking on the link to view your sitemap? If that's giving you any kind of error please let me know and we can try to troubleshoot it.

If that sitemap page is loading fine, could you try submitting the sitemap directly to Google through webmaster tools? To verify your site you can use choose the "HTML Tag" alternate verification method and use this plugin: https://wordpress.org/plugins/verify-google-webmaster-tools/

Then, if you submit the sitemap (click on the site in your Webmaster Tools, then on side look for "Crawl", then "Sitemaps", then "Add/Test Sitemap" in the top right, then put in /sitemap_index.xml in the box next to the URL) and if you get any errors, could you let me know what they are?

There seem to be a few potential issues and this'll help figure out what the problem is:
1. It looks like Yoast SEO doesn't do a great job automatically pinging Google to tell them about the sitemap. (Chris - It still hasn't found the Kairos site's sitemap that I created a couple weeks ago, despite there not being any issues with it. I just submitted it manually so we'll see what happens.)
2. Sometimes another poorly coded plugin or theme can interfere with the sitemap page and make it so that Google can't read it
3. It could be an issue with multisite, where the directory structure makes it hard for Google to find the sitemap file. Multisite might also cause it's own kind of errors in the sitemap itself.

Do you mind taking these troubleshooting steps, Chris? Thank you!

#4 Updated by Chris Caruso about 4 years ago

Thanks for the super fast and comprehensive response, Dan! We will follow these steps and let you know what happens.

Best,

Chris

#5 Updated by Boone Gorges almost 4 years ago

  • Category name set to WordPress Plugins
  • Status changed from New to Resolved
  • Target version set to Not tracked

Going to close this ticket to clear out my reports. Chris, if you have any more issues, please feel to reopen or create a new ticket. Thanks!

Also available in: Atom PDF