Project

General

Profile

Support #3966

Please download files in uploaded directory from JITP Commons space.

Added by Stephen Klein about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress - Media
Target version:
Start date:
2015-04-02
Due date:
% Done:

0%

Estimated time:

Description

Please download files in uploaded directory from JITP Commons space.

Can you leave in a dropbox or analog?

Thanks,
Stephen

History

#1 Updated by Matt Gold about 4 years ago

  • Category name set to WordPress - Media
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

Hi Boone,

Some context: JITP is an academic journal that the library seeks to have archived through JSTOR's Portico service -- http://www.portico.org/digital-preservation/

On a regular basis, that means that we need to send them files and texts for backup. The issue is exactly what we dealt with here:

http://redmine.gc.cuny.edu/issues/2599

It seems to me that we can:

1. Just submit a request every time we need a download of files

2. Set up a chron job to automate this on a regular basis.

Can you please let Stephen and me know what would be most advisable? If you have questions about the process involved, please let us know. thank you for your work.

#2 Updated by Boone Gorges about 4 years ago

  • Status changed from Assigned to Resolved
  • Target version set to 1.7.18

I've created a tool that adds a submenu to Dashboard > Media, called Download All. On this new panel, there is a button that can be clicked at any time to generate a zip file of all files uploaded to the specific site. Note that the panel is available only to Administrators on the site. https://github.com/cuny-academic-commons/cac/commit/82656c3d406944200a07a10b63a67ee9ad9fed39

The tool will be available after our next release on the 11th. I will update this ticket at that time.

#3 Updated by Matt Gold about 4 years ago

That's so fantastic. Thank you, Boone!!

#4 Updated by Stephen Klein about 4 years ago

Yes, thanks!

Also available in: Atom PDF