Project

General

Profile

Support #3983

Bug in list category posts plugin

Added by Gina Cherry about 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2015-04-09
Due date:
% Done:

0%

Estimated time:

Description

The list category posts plugin should (or once did) support custom taxonomies: https://wordpress.org/support/topic/syntax-for-custom-taxonomies. Unfortunately, I cannot get this to work and I saw several more recent posts indicating that others have had the same experience. Could we get this functionality working again on our end?

History

#1 Updated by Matt Gold about 4 years ago

  • Category name set to WordPress Plugins
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

#2 Updated by Boone Gorges about 4 years ago

Gina, can you please describe the steps needed to reproduce your problem so that I can test? How are you generating custom taxonomies, and in what sense should the plugin "support" it? Through the 'taxonomy' attribute of the shortcode?

#3 Updated by Gina Cherry about 4 years ago

We have two plugins that generate custom taxonomies: Projects and Event Manager. I tested it with the events custom taxonomy using the taxonomy attribute of the shortcode.

#4 Updated by Boone Gorges about 4 years ago

Thanks, Gina. It looks like the plugin inadvertently dropped support for custom taxonomies in version 0.54. Let me see how hard it is to fix it. I do not want us to run our own fork of the plugin, but it looks like the author is willing to accept improvements.

#6 Updated by Boone Gorges about 4 years ago

Looking at this a bit more closely, it appears that you can query custom taxonomies using this plugin, but it's not very clear how to do it. You have to couple the 'taxonomy' attribute with the 'tags' attribute, and the value of 'tags' must be the slug of your term. So if you have a taxonomy 'project-category' and a term 'Cool Projects' and the slug 'cool-projects', the following should work:

[catlist taxonomy='project-category' tags='cool-projects']

Let me know if this works for you.

#7 Updated by Boone Gorges almost 4 years ago

  • Tracker changed from Bug to Support
  • Status changed from Assigned to Resolved
  • Target version set to Not tracked

Tentatively closing this ticket as resolved. Gina, let me know if you need further assistance.

Also available in: Atom PDF