Project

General

Profile

Bug #40

Notification won't go away

Added by Gina Cherry about 12 years ago. Updated about 12 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
-
Start date:
2009-10-13
Due date:
% Done:

0%

Estimated time:

Description

I have a notification "2 accepted group membership requests." This notification will not go away when I click on it (unlike other notifications, which do).

History

#1 Updated by Matt Gold about 12 years ago

  • Category name set to BuddyPress (misc)
  • Assignee set to Boone Gorges

#2 Updated by Matt Gold about 12 years ago

  • Status changed from New to Assigned

#3 Updated by Boone Gorges about 12 years ago

Gina, will you clarify the behavior please? Did you click on the notifications themselves (ie the text "2 accepted...") or the Notifications button on the grey bar? The way BP works, as I understand it, is that clicking the Notifications button will NOT, and is not really supposed to, made the new notifications message go away. You have to click the notifications themselves, ie the text that drops down when you hover over the Notifications button.

I'm about to send you a friendship request so you'll have a notification to test with.

If what I've written accurately describes your experience, then it's not a bug, it's a feature! An annoying feature. I will work on a patch that makes notifications go away once they've been viewed, like Facebook works.

If the notifications are there even after clicking on the text itself, then we may have a real bug on our hands. I was unable to reproduce it, though.

#4 Updated by Gina Cherry about 12 years ago

Boone - I clicked on the notification text. All my other notifications go away when I click on them. This one notification has been there for a couple of months.

#5 Updated by Boone Gorges about 12 years ago

  • Status changed from Assigned to Reporter Feedback

OK, that sounds like a bug. I have located and deleted the two notifications in question. I'll consider this an isolated incident and mark the ticket as resolved (pending Gina's verification that the notifications are gone).

#6 Updated by Boone Gorges about 12 years ago

  • Status changed from Reporter Feedback to Resolved

Haven't heard otherwise from Gina, so I assume the notifications are gone. Gina, no need to respond if everything is looking good.

Also available in: Atom PDF