Project

General

Profile

Bug #4083

My Commons: New users see empty "group joined" activity items

Added by Raymond Hoh over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
My Commons
Target version:
Start date:
2015-05-25
Due date:
% Done:

0%

Estimated time:

Description

When a new user joins CAC and goes to the "My Commons" page, that user will see tons of empty "group joined" activity items.

These are just some of the numerous examples on cdev:
http://cdev.gc.cuny.edu/wp-admin/network/admin.php?page=bp-activity&aid=248113&action=edit
http://cdev.gc.cuny.edu/wp-admin/network/admin.php?page=bp-activity&aid=224703&action=edit
http://cdev.gc.cuny.edu/wp-admin/network/admin.php?page=bp-activity&aid=224700&action=edit

The problem is because of older "group joined" activity items being recorded with the group ID of 0. The last instance of this was over a year ago with most of them being recorded between 4-5 years ago.

Boone - Since the empty activity group scope relies on group ID 0, I plan on changing the group scope arguments on CAC to check for some invalid query like 'component = -1'. Let me know if you're okay with this or if you'd rather solve this by deleting all the invalid "group joined" activity items.

History

#1 Updated by Raymond Hoh over 6 years ago

Boone - I pushed a commit detailing what I mentioned above. Feel free to revert.

#2 Updated by Boone Gorges over 6 years ago

  • Status changed from New to Resolved

I wonder where these broken activity items come from.

Your fix looks good to me. Thanks, Ray!

Also available in: Atom PDF