Project

General

Profile

Bug #4489

Events Calendar iCal Download Time shift

Added by Stephen Real about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Events
Target version:
Start date:
2015-08-25
Due date:
% Done:

0%

Estimated time:

Description

I utilized the download iCal link to add 5 meetings (one at a time of course) to my Mac calendar. The first meeting worked perfectly, but the next 4 shifted the time one hour later than the meeting is scheduled in the Events Calendar. All five meetings are supposed to begin at 1:00 pm, but the last 4 show on my calendar begin at 2:00pm. I have attached one of the .ics files that created an incorrect entry as well as the one that created a correct entry.

event-organiser_2015-08-25.ics (853 Bytes) event-organiser_2015-08-25.ics Stephen Real, 2015-08-25 05:53 PM
event-organiser_2015-08-25-2.ics (854 Bytes) event-organiser_2015-08-25-2.ics Stephen Real, 2015-08-25 05:53 PM
event-organiser_2015-08-27_MG.ics (265 Bytes) event-organiser_2015-08-27_MG.ics Stephen Real, 2015-08-27 04:18 PM
event-organiser_2015-08-27.ics (877 Bytes) event-organiser_2015-08-27.ics Stephen Real, 2015-08-27 04:18 PM

History

#1 Updated by Boone Gorges about 4 years ago

  • Category name set to Events
  • Assignee set to Raymond Hoh

Ray, could you look into this please?

#2 Updated by Raymond Hoh about 4 years ago

I think this might have something to do with Daylight Savings Time.

On the Commons, under "Settings > General", we have the timezone set to UTC-4; we should set the timezone to "America/New York" and this should fix the problem.

If this doesn't immediately fix the problem, we'll have to clear the cache so Event Organiser sees the new timezone.

#3 Updated by Boone Gorges about 4 years ago

Steve, can you verify that the first of these (event-organise_2015-08-25.ics) is the one that does not work? I just changed the timezone setting and reexported the ICS file, but the file itself is identical to yours aside from the generated date.

#4 Updated by Stephen Real about 4 years ago

Boone,
Actually, it's *.ics-2 that does not work. It creates a meeting on my local Calendar for August 28 at 2:00 pm.

*.ics creates a meeting for November 20 at 1:00 pm. If you go to the Subcommittee Group and look at the Events, both meetings appear there scheduled at 1:00 pm. Where did you change the Time Zone?

#5 Updated by Raymond Hoh about 4 years ago

I can verify that the problem is with the August entry (the second ICS file), not the November one. Sorry!

However, changing the timezone in the WP admin dashboard to "America/New York" should have fixed the issue.

After looking into this a bit more, the reason is Event Organiser tries to be "smart" by converting UTC-offset timezones over to their city-equivalent. Unfortunately, in EO, UTC-4 translates over to "America/Porto Acre", which is currently using UTC-5.

Steve, can you re-download the ICS file for the August event and see if that fixes things?

Where did you change the Time Zone?

Event Organiser doesn't currently have the ability to set the timezone for specific events. EO relies on the global WordPress timezone setting at the moment.


Update: Added an issue to the Event Organiser repo - https://github.com/stephenharris/Event-Organiser/issues/287

#6 Updated by Stephen Real about 4 years ago

Ray,
It's looking to me like a Daylight Savings issue. August is still wrong as are September, October and May. However, December, January and February are all downloading correctly.

#7 Updated by Raymond Hoh about 4 years ago

Hi Steve,

I just cleared the cache. Can you try again?

I just downloaded the ICS file for the August event and I'm getting 5pm UTC (1pm Eastern).

#8 Updated by Stephen Real about 4 years ago

Ray,
Just finished testing and the August meeting is coming in with the right time. Yay! I also made sure that the winter meetings were downloading correctly and they are.

I think I may have found another bug, though, with the ical download. In doing this testing I happened to try downloading an event that Matt had created. That download did not work in the sense that it did not put an event on my calendar. The file downloaded, but it is much smaller than the other ics files that I downloaded. I have attached two files. One is the event that Matt created with MG at the end of the name. The other is one from an event that I created that worked properly.

#9 Updated by Boone Gorges about 4 years ago

  • Status changed from New to Resolved
  • Target version set to Not tracked

I'm guessing that this is due to some sort of privacy setting related to the post's post_status.

Stephen, can I ask you to open a separate issue for this issue? The original one seems to be resolved, so it'd be nice to start a new ticket in a new milestone for the separate bug. Please be sure you provide URLs for each of the events whose iCal files you downloaded.

Also available in: Atom PDF