Project

General

Profile

Bug #4542

Emailing group users problem

Added by Marilyn Weber about 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2015-09-02
Due date:
% Done:

0%

Estimated time:

Description

Boone -
A user writes:
I have been attempting to email all users of my site—the BMCC Writing Accountability Group (to remind them to write) but I get this message when I click “email users: "
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.”

I can't replicate the problem myself. Let me know if you need more info.
- Marilyn

History

#1 Updated by Matt Gold about 6 years ago

FYI, this is apparently from the dashboard of a blog.

Marilyn, did you ask her whether she is using a plugin for this?

#2 Updated by Marilyn Weber about 6 years ago

No plugin, she confirms

#3 Updated by Boone Gorges about 6 years ago

  • Status changed from New to Reporter Feedback

I am confused about what's being clicked. Can I please get specific details on how to reproduce? URLs or screenshots, where applicable, would be helpful.

#4 Updated by Marilyn Weber about 6 years ago

  • Status changed from Reporter Feedback to New

If you'd like to talk to Megan directly, she's at

#5 Updated by Marilyn Weber about 6 years ago

I did pass on your request for more info.

#6 Updated by Marilyn Weber about 6 years ago

She writes:
I log into the commons, go to my site, click settings, then 'email users.'
My email is <mailto:>.

Also,
It's not a group-just a blog/site. Is that the problem?

#7 Updated by Boone Gorges about 6 years ago

  • Category name set to WordPress Plugins
  • Priority name changed from High to Normal
  • Target version set to 1.8.10

Thanks, Marilyn.

Matt, as you guessed, this is due to a plugin. The plugin is "CAC Email Users", which is our old fork of https://wordpress.org/plugins/email-users/. The public plugin has been updated extensively in the past few years, including fixes for the issue being encountered in this ticket (menus being added incorrectly to the Dashboard menu).

I just generated a diff between our fork and the version of email-users we originally forked from. It looks like the only meaningful changes I made were to make the user queries multisite-aware. From what I can see, the plugin has fixed these issues as well.

My suggestion is as follows. In 1.8.10, we retire and remove our cac-email-users fork and add email-users. At that time, I'll manually activate the new plugin on the sites where the old plugin is currently active (as I write this, there are only 9 of them). Any objections?

#8 Updated by Matt Gold about 6 years ago

Sounds good. Thanks, Boone. What should we tell this particular user?

#9 Updated by Boone Gorges about 6 years ago

Let's tell her that the Email Users functionality will begin working after our next release on September 11.

#10 Updated by Boone Gorges about 6 years ago

  • Status changed from New to Hold

Plugins swapped out in https://github.com/cuny-academic-commons/cac/commit/46e6f1a187c26c01cd106b7a88c7dde8ea1dfecf. I'll leave the ticket open as a backup reminder that I need to manually process sites using cac-email-users after the release.

#11 Updated by Marilyn Weber about 6 years ago

I let the user know. Thanks!

#12 Updated by Boone Gorges about 6 years ago

  • Status changed from Hold to Resolved

The new plugin is live, and has been activated on the half-dozen sites where the old plugin used to be active. I'm going to mark the issue resolved. Marilyn, please let me know if the user continues to report issues.

Also available in: Atom PDF