Project

General

Profile

Bug #4760

email notification contains broken image

Added by Matt Gold over 3 years ago. Updated over 3 years ago.

Status:
Rejected
Priority name:
Normal
Assignee:
Category name:
Email Notifications
Target version:
Start date:
2015-10-08
Due date:
% Done:

0%

Estimated time:

Description

An email notification of a blog post with an image contained what looks like a broken image in the notification.

(n.b. I have images turned off from automatically appearing in Gmail, but I don't think that is affecting things in this case, as when it does I usually see an option to show the image in question)

History

#1 Updated by Boone Gorges over 3 years ago

It appears that the markup used to embed the image in the original blog post is incorrect: http://dhpraxis15.commons.gc.cuny.edu/2015/10/08/new-dhdebates-cfp-is-up/ Note that the linked image goes to the right place, but the src attribute of the img tag is incorrect.

Do you recall how you embedded the image? Did you write the markup by hand, or were you using the Add Media button?

#2 Updated by Matt Gold over 3 years ago

Do you recall how you embedded the image? Did you write the markup by hand, or were you using the Add Media button?

Hmm. I used the Add Media button in Text editor mode

#3 Updated by Boone Gorges over 3 years ago

  • Status changed from Assigned to Reporter Feedback
  • Target version set to Not tracked

Looking more closely at this, I'm fairly certain it was user error. Here's the markup:

<a href="https://dhpraxis15.commons.gc.cuny.edu/files/2015/10/Screen-Shot-2015-10-08-at-6.25.26-PM.png"><img class="alignnone size-medium wp-image-137" src="http://dhdebates.gc.cuny.edu/cfps/cfp_2017_ddh" alt="Screen Shot 2015-10-08 at 6.25.26 PM" width="300" height="221" /></a>

It's pretty clear that the URL that the link goes to (href) and the image URL (src) are switched around. I know you said you used the Add Media button, but I have a feeling that's not the whole story :) Perhaps you could test creating (only as a draft) another copy of the post in question, taking the same steps you took to create the original (so far as you can remember them) to see if you can reproduce the problem.

#4 Updated by Matt Gold over 3 years ago

  • Status changed from Reporter Feedback to Rejected

Okay. I do remember looking at the printed out text, looking for a place to add an alt tag, so maybe I pasted something in there. I have since published posts with images uploaded in the same way, and they came through in the notification, so let's close this now and I will reopen if this happens again.

Also available in: Atom PDF