Project

General

Profile

Bug #4761

Forum Posts, Slow to Submit

Added by Luke Waltzer almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Group Forums
Target version:
Start date:
2015-10-09
Due date:
% Done:

0%

Estimated time:

Description

I've been posting in forums for the past couple of days and have noticed it's taking 3-5 seconds for posts to go through after I submit them. I don't have baseline data on load times and performance here, but that seems longer than it used to take.

Possible to put on the roadmap an assessment of load times there and perhaps some exploration of ways to speed things up a bit?

Fwiw, as I'll be using to Commons more intensively now that I'm at the GC, and would be happy to take on a more significant UX review role... ready to serve when the time is right.


Related issues

Related to CUNY Academic Commons - Bug #10654: Trashing bbPress item can cause one zillion db queriesResolved2018-11-01

History

#1 Updated by Boone Gorges almost 4 years ago

  • Category name set to Group Forums
  • Assignee set to Boone Gorges
  • Target version set to 1.8.14

Thanks for the report, Luke. I'll take some time to look into it.

#2 Updated by Boone Gorges almost 4 years ago

  • Status changed from New to Resolved
  • Target version changed from 1.8.14 to 1.8.13

I had to test some forum-related stuff and noticed how awful this was, so I decided to look into it sooner rather than later.

The problem is that bbPress is triggering a topic/reply count recalculation every time a reply is posted. I don't know why this just started becoming apparent recently - I took a quick look at the bbPress logs, but it seems like this "feature" has been baked into bbPress since time immemorial.

I've put a truly unholy workaround into place in https://github.com/cuny-academic-commons/cac/commit/dd7dd9cdd64b2182f9977265c4ac56f1ad8ec098 and I'm going to ship it in 1.8.13. Luke, can I ask you to test again after tonight's release, and let me know whether you notice a difference?

#3 Updated by Matt Gold almost 4 years ago

Wow. Thank you for bringing this to our attention, Luke

#5 Updated by Boone Gorges 9 months ago

  • Related to Bug #10654: Trashing bbPress item can cause one zillion db queries added

Also available in: Atom PDF