Project

General

Profile

Bug #4831

User cannot update profile

Added by Marilyn Weber about 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Public Portfolio
Target version:
Start date:
2015-10-28
Due date:
% Done:

0%

Estimated time:

Description

A user reports that while she can access the Edit Profile page and can click on Submit Changes, she is then returned to the Editing page and her changes never appear. I tried to duplicate the problem and could not; it worked fine for me.

Here is what I asked her and how she replied:
Marilyn Weber Today 14:21
Please confirm the following:
1) You are able to access the editing page (http://commons.gc.cuny.edu/members/YOURNAME/profile/edit/group/1/) which shows you boxes that ask for "Full Name," "Brief Descriptor," "About You", etc.
2) At the bottom of that page, you see a button that says "Save Changes"
3) When you click that button, you are taken to a page (http://commons.gc.cuny.edu/members/YOURNAME/) which shows your avatar on the right and does not show field boxes
Thanks!

Mara Gittleman 41 minutes ago
1) yes
2) yes
3) NO - it just takes me back to the same page where I can edit fields

History

#1 Updated by Boone Gorges about 6 years ago

Marilyn, could you please ask the reporter for some more details about the kinds of edits being made? For example, did the user add lots of widgets with large amounts of text?

#2 Updated by Marilyn Weber about 6 years ago

She tried to change her phone number and email address.

#3 Updated by Boone Gorges about 6 years ago

I'm also unable to reproduce any problems.

I checked the error logs to see if anything jumped out for this specific user's URLs, but I didn't see anything out of the ordinary.

Could you ask the user to test with another browser, on the off chance that the problem is due to some weirdly sticky browser cache?

#4 Updated by Marilyn Weber about 6 years ago

She replies:

I've tried chrome and firefox, mac and windows. I first made a profile in 2010. Perhaps the profiles have changed, and maybe there's an error message that I can't see? An error in one of the old fields? I may just need to delete my account and start over - please let me know if you think that will be necessary.

#5 Updated by Marilyn Weber about 6 years ago

Should I take her up on her offer to delete the account and start over?

#6 Updated by Boone Gorges about 6 years ago

No, no, please do not have her do that.

I have been away for the weekend, but will try to look at this today.

#7 Updated by Boone Gorges about 6 years ago

  • Category name set to Public Portfolio
  • Assignee set to Boone Gorges
  • Target version set to 1.8.16

I've done some debugging, and it's possible that the reason the data is not being saved is because a required field is not being filled out. Specifically, all users must have a value for "Role", and I see that this user does not. Could you ask her to test again, being sure to fill in all fields marked Required?

It appears that we don't provide any feedback when users forget these fields. We should do so.

#8 Updated by Marilyn Weber about 6 years ago

Hooray! She replies:
That did it. Thank you! In the future, an error message would be super helpful here

We can close this ticket, I think

#9 Updated by Boone Gorges about 6 years ago

Great!

I'm going to leave the ticket open as a reminder to add some error feedback.

#10 Updated by Boone Gorges about 6 years ago

  • Target version changed from 1.8.16 to 1.8.17

#11 Updated by Boone Gorges about 6 years ago

  • Target version changed from 1.8.17 to 1.8.18

#12 Updated by Raymond Hoh about 6 years ago

  • Target version changed from 1.8.18 to 1.9

#13 Updated by Boone Gorges almost 6 years ago

  • Target version changed from 1.9 to 1.9.1

#14 Updated by Boone Gorges almost 6 years ago

  • Target version changed from 1.9.1 to 1.9.2

#15 Updated by Boone Gorges almost 6 years ago

  • Target version changed from 1.9.2 to 1.9.3

#16 Updated by Boone Gorges almost 6 years ago

  • Target version changed from 1.9.3 to 1.9.4

#17 Updated by Boone Gorges almost 6 years ago

  • Status changed from New to Resolved

In https://github.com/cuny-academic-commons/cac-advanced-profiles/commit/d24aaf40c13c574c8add0e49bb0676433a54106d I update the header-edit template so that BP's native error messages appear when required fields have not been filled in.

Also available in: Atom PDF