Project

General

Profile

Bug #4846

Unable to Place Logo in Make theme

Added by Luke Waltzer almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Themes
Target version:
Start date:
2015-11-02
Due date:
% Done:

0%

Estimated time:

Description

Trying to place a logo in the Make theme at tlc.gc.commons.cuny.edu; can upload via https://tlc.commons.gc.cuny.edu/wp-admin/customize.php?url=http%3A%2F%2Ftlc.commons.gc.cuny.edu%2F, but logo does not appear in header.

Screenshot:

History

#1 Updated by Boone Gorges almost 6 years ago

  • Category name set to WordPress Themes
  • Status changed from New to Resolved
  • Assignee set to Boone Gorges
  • Target version set to 1.8.15

Oof, this was not very fun to track down. It turns out that there is a bug in the way that Make handles SSL configurations like ours, with the result that attachment lookups were failing when you were attempting to insert the logo. I've opened an upstream PR: https://github.com/thethemefoundry/make/pull/290

Fixed on the Commons in https://github.com/cuny-academic-commons/cac/commit/8d48b13c3a06313187f9365193a0f4bcbd721d27

#2 Updated by Matt Gold almost 6 years ago

Jeez. Thanks, Boone.

#3 Updated by Luke Waltzer almost 6 years ago

FYI, this is still buggy in the Make interface (see tlc.commons.gc.cuny.edu for example). I was able to upload and select a new logo yesterday, and though it's displaying properly on my desktop a) it's not showing as selected in the Theme Customization editor and b) the theme is displaying an older version of the logo when I view on mobile (visible via mobile view using Chrome/Inspect Element and confirmed on iPhone 6).

Thx,
L

#4 Updated by Boone Gorges almost 6 years ago

Hi Luke - I'm unable to reproduce either the Customizer or the mobile issue - though both experiences are buggy in their own way, the correct logo does appear to be showing. In both cases, it's possible that a sticky cache is to blame. In any case, it appears to be unrelated to the SSL fix that was the original subject of this ticket (preventing you from setting the logo in the first place), so if you continue to have problems, could I ask you to open a separate ticket?

#5 Updated by Luke Waltzer almost 6 years ago

Mobile issue resolved... cache was the issue, I think.

I'm still seeing the customizer issue... screenshot attached. Where it says "No Logo Selected" the current logo should appear. I was able to swap out and in new logos, so functionally it's resolved. My instinct is that it is still related to the original issue, but it's a decided non-emergency. Just want the history to be up to date in case any other tickets come in.

Also available in: Atom PDF