Project

General

Profile

Bug #499

Help with Atahualpa Issues

Added by Matt Gold over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2010-12-18
Due date:
% Done:

0%

Estimated time:

Description

Hi Scott,

Can you jump in and lend a hand on this help forum post: http://commons.gc.cuny.edu/groups/wordpress-help/forum/topic/customize-theme-installation/#post-3397

Thanks,

Matt

History

#1 Updated by scott voth over 10 years ago

Hi Matt - I can see how you can change the background image and the logo in Atahualpa (and I replied to the forum), but how to change the rotator images? It used to be that you just uploaded an image to your media files with the same naming convention, but now they seem to abandoned that method. I can look at this later today (I've got to go out right now), but I am a little stumped on this one.

#2 Updated by Matt Gold over 10 years ago

Not sure. Boone? Chris?

#3 Updated by Boone Gorges over 10 years ago

The documentation makes it look like the old method has been abandoned, but a look at the code suggests otherwise. It looks like the theme should look in your uploaded files (Dashboard > Media) for files named atahualpa_header_X, where X is an integer.

Has anyone actually tested this?

#4 Updated by scott voth over 10 years ago

Hi Boone - yeah, in the code it still seems to look for the images in the upload folders first, but I've tried using that naming convention (atahualpa_header_1, atahualpa_header_2, atahualpa_header_3...), but they never get picked up. At first I thought it was because the files were .JPG rather than .jpg, but I tried png, jpg, and jpeg extensions, but none of them seemed to work. Also tried creating a completely new blog with that theme, but didn't work either.

#5 Updated by Boone Gorges over 10 years ago

  • Status changed from Assigned to Reporter Feedback
  • Target version changed from Not tracked to 1.1.5

You're right, Scott. I took a closer look and there were a few bugs in Atahualpa that were causing the problem. One is that they were using an outdated way of testing for a multisite installation that broke after WP 3.0. Another is that the regex they were using to find header images in the uploads folder was incorrectly written.

I fixed both bugs in https://github.com/castiron/cac/commit/b931228bd1c01d9b8281ddfe4adcd2af1a534bc8. Scott, can I ask you to test these changes on cdev before you contact the reporting member and I mark the ticket resolved?

BTW I submitted the patches to the authors of Atahualpa. Hopefully they'll be included in the next version.

#6 Updated by Matt Gold over 10 years ago

You rock, Boone.

But you knew that already.

#7 Updated by Boone Gorges over 10 years ago

  • Status changed from Reporter Feedback to Resolved

Marking Resolved because I just released the fix. Scott, if it doesn't work, please reopen.

#8 Updated by Matt Gold over 10 years ago

Scott -- If this is indeed resolved and released, can you update the WordPress Help! thread on the topic? Please point them to this ticket and to Boone's update post on the Dev blog, and please explain the fix. Many thanks!

#9 Updated by Boone Gorges over 10 years ago

Most importantly, explain how to make the personalized header actually work. Upload files at Dashboard > Media with the right naming schema, etc.

#10 Updated by Matt Gold over 10 years ago

Hi Scott,

I just saw that you posted to that thread, but it doesn't look like you have yet revealed that we resolved the issue. Please do so when you have a chance and explain to people how to make the image headers work. thank you!

Matt

#11 Updated by scott voth over 10 years ago

Yes, I don't think the issue is totally resolved - though it's a hundred times closer! The images from the download folder are now getting displayed - but as Aaron notes (and I've confirmed), they are getting randomly "scaled" - so, for example - in my sandbox blog, I have just two images - but they appear in random widths (and actually overlay each other sometimes). It's weird. I tried to see if there was a setting that does this - but didn't see it.

#12 Updated by scott voth over 10 years ago

Sorry - here's a link to what I'm talking about http://sandboxdescott.commons.gc.cuny.edu/

#13 Updated by Matt Gold over 10 years ago

Scott -- according to your posts on the WordPress Help!! group, it sounds like this problem isn't actually resolved. Can you explain?

#14 Updated by scott voth over 10 years ago

Hi - When pulling images from WP upload folders, the images now appear in the rotator slideshow, but they are for some reason randomly re-sized - very odd. See http://sandboxdescott.commons.gc.cuny.edu/
I wonder if it's because the images are not identically sized? One is 600x322, and the other is 600x90. But it was happening on just one image on Aaron's blog, taking the same image and scaling back and forth. I will look some more - but have to go to work now.

#15 Updated by Boone Gorges over 10 years ago

  • Status changed from Resolved to Assigned

#16 Updated by Boone Gorges over 10 years ago

  • Tracker changed from Support to Bug

#17 Updated by Boone Gorges over 10 years ago

  • Target version changed from 1.1.5 to 1.1.6

#18 Updated by Boone Gorges over 10 years ago

  • Status changed from Assigned to Reporter Feedback

Part of the problem here is that I wrote the regex to be too generous. When you upload a file through Dashboard > Media, WP creates several sizes, and my regex is detecting several resized versions of each image. I have fixed this problem in https://github.com/castiron/cac/commit/8e7d746cfab112ec91b5c1cde3d95c4b7383857d

The other part of the problem (or maybe it's not a problem at all) is that Atahualpa is set to rotate through header images on reload, even when you have the JS rotate option turned off. Ideally, Atahualpa would give you an option to disable this feature, and to select a single image from the atahualpa_header_* collection to display on every page load. But that would take me a long time to build (and the Atahualpa guys might not even integrate it), so I'm instead going to suggest that if you want the same header image on every page load, you should delete all atahualpa_header_* images that you have uploaded, except for the one you want to use, making sure to save backups of those other images.

Does that sound like a reasonable course? If so then I will mark this ticket Resolved and roll the regex fix into 1.1.6.

#19 Updated by scott voth over 10 years ago

Sounds great. Also, if the user just wants a static page, there are other ways to do it. Thanks for your help!

#20 Updated by Boone Gorges over 10 years ago

  • Status changed from Reporter Feedback to Resolved

Great - thanks, Scott!

#21 Updated by scott voth over 10 years ago

One thing I noticed in this seemingly endless saga - once you create images in your upload folder, with that naming convention - they seem to be with you forever. It seems like they get moved to the other folder (like Shawn mentioned)? I was looking into Rowena's issue, and I thought I could just delete all my header images and go back to the defaults, but it seems like once you take the plunge, you're kind of married to supplying those images. They remain with you, and its not a caching issue. I switched browsers, and they were still there. Probably not really an issue, but rather an interesting feature of Atahualpa.

Also available in: Atom PDF