Project

General

Profile

Bug #5188

Not allowed to edit social paper

Added by Raffi Khatchadourian over 5 years ago. Updated over 5 years ago.

Status:
Rejected
Priority name:
Normal
Assignee:
Category name:
Social Paper
Target version:
Start date:
2016-01-30
Due date:
% Done:

0%

Estimated time:

Description

I tried to disable editing for https://commons.gc.cuny.edu/papers/cuny-cat-meeting-notes-1292016/ but I receive the error, "You are not allowed to edit this item."

Screen Shot 2016-01-30 at 11.43.18 AM.png (462 KB) Screen Shot 2016-01-30 at 11.43.18 AM.png Screenshot. Raffi Khatchadourian, 2016-01-30 12:02 PM

History

#1 Updated by Boone Gorges over 5 years ago

  • Assignee set to Raymond Hoh
  • Target version set to 1.9.7

Ray, could you try to reproduce and diagnose, please?

#2 Updated by Raymond Hoh over 5 years ago

  • Status changed from New to Reporter Feedback

I wasn't able to reproduce Raffi's bug.

I created a private paper, then I reopened the paper and edited it. Next, I toggled the "Enable Editing" button and could not duplicate the error.

Looking into the source, it looks like the "You are not allowed to edit this item" notice appears if the AJAX nonce is invalid:
https://github.com/cuny-academic-commons/social-paper/blob/master/includes/class-cacsp-fee.php#L37-L39

Raffi, did you do anything unique to get this notice to show up? Did you leave the paper open overnight and then resumed editing?

#3 Updated by Raymond Hoh over 5 years ago

  • Assignee changed from Raymond Hoh to Raffi Khatchadourian

#4 Updated by Boone Gorges over 5 years ago

  • Target version changed from 1.9.7 to 1.9.8

#5 Updated by Raffi Khatchadourian over 5 years ago

  • Assignee changed from Raffi Khatchadourian to Raymond Hoh

Sorry guys, this one fell through the cracks. Yes! I believe I was idle for some time, but, I don't know how much time.

#6 Updated by Raymond Hoh over 5 years ago

  • Status changed from Reporter Feedback to Rejected

Thanks for getting back to me, Raffi. I'm going to close this ticket for now to clear the milestone.

If you are able to duplicate this again, please reopen and let us know how to replicate the issue.

Also available in: Atom PDF