Project

General

Profile

Bug #5239

Inconsistent search results between google custom search and groups search box

Added by Raffi Khatchadourian over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Search
Target version:
Start date:
2016-02-19
Due date:
% Done:

0%

Estimated time:

Description

Steps to reproduce
  1. Visit https://commons.gc.cuny.edu/groups.
  2. Select "All Groups."
  3. Enter "software" in the "Search groups..." box. The search on 2/19/2016 on 14:02 EST returned fifteen results.
  4. Enter "software" in the "Google custom search..." box. The search on 2/19/2016 on 14:02 EST returned no results.

History

#1 Updated by Matt Gold over 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

#2 Updated by Boone Gorges over 5 years ago

  • Status changed from Assigned to Resolved
  • Target version set to 1.9.8

Thanks for the report, Raffi.

Search results between BP's built-in search and the Google CSE are always going to differ somewhat. Until we implement some more sophisticated solution for search across the Commons (#3002), this is something we'll have to live with.

However, you have uncovered a legitimate bug: the Google CSE results page doesn't show anything when loading the site over HTTPS. That's because the Google script is being loaded from a hardcoded non-secure URL, which browsers block by default. This is fixed in https://github.com/cuny-academic-commons/cac/commit/90e6a368ca6db92a78ccfdf961e7ea1f19302b83

Also available in: Atom PDF