Project

General

Profile

Bug #56

Addition of a Profile Field Option Removes Existing One

Added by Matt Gold over 12 years ago. Updated over 12 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
-
Start date:
2009-10-25
Due date:
% Done:

0%

Estimated time:

Description

Last week, we had a request to add the School for Professional Studies to our profile field options. I added it, but what appears to have happened is that the act of adding SPS removed one of our existing options -- CUNY Central (I believe that that was the option most recently added before SPS).

I just went and tried to re-add CUNY Central, but doing that removed SPS.

Any help that you can give me would be appreciated. Profile fields are handled through BuddyPress, and the interface can be found on the dashboard (Dashboard > BuddyPress > Profile Field Setup

One concern I have is that once we get both options fixed, that we edit the database so that we don't wind up with two groupIDs for one school

Thank you for your help with this.

History

#1 Updated by Lucas Thurston over 12 years ago

  • Status changed from Assigned to Resolved

Matt,
There seems to be a funny little bug in the select box editing interface. I noticed that when there were 24 options in the list, the last one being Option #24: Cuny Central, but when I clicked the "Add Another Option" link, the option number is the same as the last one in the list. So, I clicked "Add Another Option" and I see a field for Option #24 below the already existing Option #24. It turns out that the id of the input field is the same too, so the second value overwrites the first and you can't add one option at a time. This is a Javascript bug that we could easily fix, but I bet it will be fixed in the next version of BP, and as long as you're aware of it, it's not problem.

To work around this problem, I clicked "Add Another Option", entered "Cuny Central" for #24, clicked "Add Another Option" and entered "School for Professional Studies" for #25.

I'm closing this issue.

Lucas

#2 Updated by Matt Gold over 12 years ago

Great catch, Lucas -- thanks so much. Just to clarify: are you sure that people who have already chosen SPS or CUNY Central will be assigned the same college id number in the database?

#3 Updated by Lucas Thurston over 12 years ago

Matt,
It sounds like CUNY Central started out being option #24, and is still is option #24, so I believe the answer is yes. I haven't confirmed this, however, and probably need to dig into the code a little bit to make sure. Unless you know of any users who signed up who were from CUNY central. We could probably just check their user profiles and find the answer to our question.

Lucas

Also available in: Atom PDF