Project

General

Profile

Actions

Support #5629

closed

Title field in profile can't be edited

Added by Marilyn Weber over 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
Public Portfolio
Target version:
Start date:
2016-05-27
Due date:
% Done:

0%

Estimated time:

Description

Seogjoo Jang would like to change her profile from Associate Professor to Professor in her "Title" field - http://commons.gc.cuny.edu/members/sjang/. When I look at my own profile, I don't see Title as an option. Scott suggests "It may be that she has a portfolio that was created before current enhancements and cannot edit. If so maybe Boone can remove the old and allow her to re-enter using new fields."

Boone, can you take a look? Thanks!

Actions #1

Updated by Boone Gorges over 6 years ago

  • Status changed from New to Reporter Feedback

Hi Marilyn - It shouldn't be necessary to delete the field. As soon as the user has entered at least one item in the Positions widget, the Title field will go away. Could you give that a try and let me know if it works as described?

Actions #2

Updated by Marilyn Weber over 6 years ago

Thanks! I can't replicate this to test it out, but I've passed on this solution to the user and will let you know if/when she replies.

Actions #3

Updated by Boone Gorges over 6 years ago

  • Category name set to Public Portfolio
  • Status changed from Reporter Feedback to Resolved
  • Target version set to Not tracked

Going to close this ticket to clean out the inbox. Marilyn, please do pass along any info you may get from the user, and definitely reopen this ticket if there's still a problem. Thanks!

Actions #4

Updated by Marilyn Weber about 6 years ago

Boone -

This widget is indeed still problematic. When I try to add anything at all, the screen flashes red and the changes are not saved. A user who already has a title in there cannot update it either. Does it work for you?

Actions #5

Updated by Boone Gorges about 6 years ago

Thanks for the additional info, Marilyn. When you say "the widget", which one do you mean - 'Title' or 'Positions'? As noted above, it's by design that 'Title' cannot be edited. Once the user has created and saved a 'Positions' widget, the 'Title' widget will no longer appear. (I just tested 'Positions' and it seems to be working fine.)

Actions #6

Updated by Marilyn Weber about 6 years ago

I meant Positions. The red flashing was only happening for me, but now the widget works for both of us. Sorry for the false alarm! Please close this ticket.

Actions #7

Updated by Boone Gorges about 6 years ago

Thank you, Marilyn! (The red flashing will happen if you are editing one field and then try to edit another one.)

Actions #8

Updated by Marilyn Weber almost 6 years ago

  • Status changed from Resolved to New
  • Assignee deleted (Boone Gorges)

Joe Rosenberg reports:
I am getting back to the academic commons after a dormant period, I see that the "Title" field is "deprecated" and can't be edited, however, I no longer have the same title (mine says: "Professor and Interim Dean of Clinical Programs) but now I am "Professor" only. How can this be updated?

I replied with instructions, but he now reports:
I have tried to add a position using the widgets, and been very careful to click “save changes” after putting in “CUNY School of Law” from the drop down menu, and then “Professor of Law” for my position, but not only does it not “negate” the incorrect “Title” I cannot seem to get the position widget (or my twitter feed) to appear on my page.

I can't replicate it. Changing what's in the Position widget works fine for me.

Actions #9

Updated by Matt Gold almost 6 years ago

  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

Hi Boone -- can you please take a look at this when you have a chance? Thank you!

Actions #10

Updated by Boone Gorges almost 6 years ago

  • Status changed from Assigned to Hold
  • Assignee deleted (Boone Gorges)
  • Target version changed from Not tracked to 1.10.4

Thanks for the details, Marilyn. Joe's problem does appear to be a bug, and so probably a separate issue from what was originally discussed in this ticket.

It looks like the Positions widget is a bit flaky when adding an "incomplete" position - ie, one without a Department. But in a place like the School of Law, perhaps it's common not to have a department. I've fixed this issue in the cac-advanced-profiles plugin: https://github.com/cuny-academic-commons/cac-advanced-profiles/commit/3272f55a466d7ac74821c0c3e922342b01597542 with some additional fixes in the CAC repo. This will all be available as part of the 1.10.4 release this weekend. I'll leave this ticket open as a reminder to ping you to report back to Joe after the release.

Actions #11

Updated by Boone Gorges almost 6 years ago

  • Status changed from Hold to Resolved

The changes are now live on the server. I'm going to tentatively mark this as resolved. Marilyn, if Joe still has problems, please feel free to reopen with details.

Actions #12

Updated by Marilyn Weber almost 6 years ago

Confirming that the user says it works fine now. Thanks!

Actions #13

Updated by Boone Gorges almost 6 years ago

Thanks!

Actions

Also available in: Atom PDF