Project

General

Profile

Bug #5684

Making Group files appear as Blog entries

Added by Marilyn Weber about 3 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Group Files
Target version:
Start date:
2016-06-10
Due date:
% Done:

0%

Estimated time:

Description

Boone -
Matt asked me to request help from you about this dilemma. I'm going to have to through quite a bit of info at you here, so I'm going to have several entries under this one ticket.

HISTORY:
Five years ago, The WAC Resource Center Group was started - http://commons.gc.cuny.edu/groups/wac-resource-center/ - for Writing Across the Curriculum Fellows to share information. Two years ago, the Group was linked to a new Site, CUNY WAC Reasources - http://wacresources.commons.gc.cuny.edu/. Its stated purpose: "This site is a resource for all of CUNY’s WAC programs, collecting submissions from The WAC Resource Center group . . . You can submit new materials through the group, and discuss WAC pedagogy on the group forum. The WAC Resource Center’s most popular and most recently uploaded materials are featured in the right sidebar."

So my understanding was anyone who had something to share would simply add a file and select a folder (see screenshot) which would then allow it to appear on the site. This has worked in the past. As you can see with the next two attached screenshots. a user entered a file through the group ("Writing Fellow/Faculty Collaboration in a Community College"), selected the Folder "Being a Writing Fellow" then had it appear on the site

Selected Folder.JPG (50.7 KB) Selected Folder.JPG Marilyn Weber, 2016-06-10 12:26 PM
Writing Fellow post in Group.JPG (217 KB) Writing Fellow post in Group.JPG Marilyn Weber, 2016-06-10 12:26 PM
Writing Fellow post on Site.JPG (134 KB) Writing Fellow post on Site.JPG Marilyn Weber, 2016-06-10 12:26 PM
Test File in Group.JPG (240 KB) Test File in Group.JPG Marilyn Weber, 2016-06-10 12:44 PM
Test File not on Site.JPG (156 KB) Test File not on Site.JPG Marilyn Weber, 2016-06-10 12:44 PM
Page Dashboard.JPG (263 KB) Page Dashboard.JPG Marilyn Weber, 2016-06-10 12:56 PM

History

#1 Updated by Matt Gold about 3 years ago

  • Category name set to Blogs (BuddyPress)
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

And my understanding is that there is no syncing between Group Files and content on Blog pages. According to my understanding, the only thing that syncs between groups and blogs are the member status/permissions, and feeds between the two (e.g. a group email notification is created when a blog post is posted if the two have been linked)

#2 Updated by Marilyn Weber about 3 years ago

PRESENT:

Some posts are not showing up. There are three reasons for that as far as I can see:
1) The uploader did not check a folder. This human error can be fixed, obviously.
2) But sometimes it is because the group folder options do not match the headings on the site. I can't figure out how to have new headings that will pull from the folders.
3) Most disturbingly, sometimes (as with my just created "Test" file) it is for no reason I can discern. Attached screenshots for test file

On our Friday call, Matt expressed surprised that the groups could supply documents for the sties, if I understood correctly. But that seems to be exactly what the "Writing Fellow" screenshots show. If it worked then, shouldn't it work now?

#3 Updated by Marilyn Weber about 3 years ago

FUTURE:

It seems to me that all this could be resolved by creating a new site wherein all the information is resubmitted as blog entries by anyone who Julia Fuller (the admin) wants to add as a Participant.

Or we could keep the Site as is, and the admin would have to place the entries in the proper pages (screenshot again), I guess she'd have to receive the new documents via email?

If you think it's appropriate, I could sit with Julia and show her either way.

#4 Updated by Marilyn Weber about 3 years ago

  • Assignee set to Boone Gorges

re-adding Boone as assignee, not sure how he was removed!

#5 Updated by Boone Gorges about 3 years ago

  • Category name set to Group Files
  • Status changed from New to Reporter Feedback
  • Target version set to Not tracked

And my understanding is that there is no syncing between Group Files and content on Blog pages. According to my understanding, the only thing that syncs between groups and blogs are the member status/permissions, and feeds between the two (e.g. a group email notification is created when a blog post is posted if the two have been linked)

This is my understanding as well. Marilyn, when I was reading your report, I kept thinking, "Neat! This sounds like a cool feature! We should build it!"

Regarding your screenshots. The "Recent Group Documents" widget does pull live information right from the group. But the top-level categories/pages on the group site were most likely created manually by the site administrator. Looking at these pages in the Dashboard of http://wacresources.commons.gc.cuny.edu/ strongly supports this hypothesis: "Teaching & Learning Strategies", for example, appears to have been created by Julie Fuller, with all the nice formatting etc added by hand.

Or we could keep the Site as is, and the admin would have to place the entries in the proper pages (screenshot again), I guess she'd have to receive the new documents via email?

If the above is correct, then this sounds like the right solution: in order to mirror the content, the administrator has to continue to do it manually. Email notifications should come through automatically as long as the user is subscribed to "All Email" in the group (and the files are not added with the "silent" chechbox checked).

#6 Updated by Boone Gorges almost 2 years ago

  • Status changed from Reporter Feedback to Resolved

I think there's no bug here, just an initial misunderstanding about intended behavior2, so I'm going to close the ticket. There may be some interesting feature ideas in the conversation above, so if anyone wants to pursue by opening up enhancement tickets, please feel free to do so.

#7 Updated by Matt Gold almost 2 years ago

Hi Marilyn,

Can you please try to touch base with this group to see a) whether they are still having issues, and b) still using the Commons?

#8 Updated by Marilyn Weber almost 2 years ago

I've reached out to Julie to discover the new admin.

#9 Updated by Marilyn Weber almost 2 years ago

This ticket can be closed.

Also available in: Atom PDF