Project

General

Profile

Actions

Bug #5690

closed

Log Out link showing WP-Admin Bar for logged out users on JITP

Added by Luke Waltzer over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Toolbar
Target version:
Start date:
2016-06-13
Due date:
% Done:

0%

Estimated time:
Deployment actions:

Description

Discovered that users who aren't logged into the Commons are getting both log out and log in links in the wp-admin bar on JITP. Confirmed on FF, Chrome, Safari, and FF/Windows 10. This seems specific to JITP. Guessing a plugin conflict... Hard to troubleshoot on the dev site b/c it's private. Any ideas?

Thx-


Files

Actions #1

Updated by Matt Gold over 6 years ago

  • Status changed from New to Assigned
  • Assignee set to Boone Gorges
Actions #2

Updated by Boone Gorges over 6 years ago

Looks like a bug in wp-accessibility. I have opened a PR https://github.com/joedolson/wp-accessibility/pull/9

If this is a serious issue, I can add a shim that will fix the problem on the Commons. Otherwise it's easier to wait until it's fixed in wp-accessibility.

Actions #3

Updated by Boone Gorges over 6 years ago

  • Category name set to Toolbar
  • Status changed from Assigned to Resolved
  • Target version set to 1.9.19

In https://github.com/cuny-academic-commons/cac/commit/6fdb98f393f60e922ead618e14ce7dd81ad671f5 I've updated wp-accessibility to the latest master branch from Github, so that we get this fix. The PR has been merged, and will be part of the next official wp-accessibility release.

Actions

Also available in: Atom PDF