Project

General

Profile

Support #5792

Help Managing Submissions to JITP

Added by Luke Waltzer almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
-
Target version:
Start date:
2016-07-14
Due date:
% Done:

0%

Estimated time:

Description

JITP has two submissions under review for publication this fall that have been submitted as fully-navigable sites. One is hosted in a Drupal site (http://teachmix.com/ilit/) and the other has been submitted as a complete html directory (https://drive.google.com/open?id=0B3uXJQfYlBX4VFNRX0lNZ2ZuNTQ).

We wanted to explore our options for hosting or serving these submissions on JITP while preserving their aesthetics and structure. The argument for doing so is stronger for the second piece (Bartlett, the full directory) than the Drupal site. If there’s an easy way to embed the Drupal site, we’d be interested in exploring that, but think the content could be transferred to JITP with little to no loss.

Can you please let us know what options there are on the Commons for integrating these pieces into JITP, while preserving JITP’s header/navigation/footer?

Thank you!

(posted in behalf of Amanda Licastro, Editor, JITP Issue 10). When assigning, please add Stephen Klein and Amanda Licastro as watchers.

Bartlett et al.-20161101T145050Z.zip (22.9 MB) Bartlett et al.-20161101T145050Z.zip Luke Waltzer, 2016-11-01 10:52 AM
Screen Shot 2016-11-02 at 9.38.29 PM - div blocks half of navigation button.png (541 KB) Screen Shot 2016-11-02 at 9.38.29 PM - div blocks half of navigation button.png Ben Miller, 2016-11-02 09:46 PM
bartlett revised.zip (23.3 MB) bartlett revised.zip copyedited files in a full directory for standalone html - Bartlett, More than Assessment Ben Miller, 2016-11-10 11:44 AM
bartlett 20161109 Revision More Than Assessment Files.zip (22.7 MB) bartlett 20161109 Revision More Than Assessment Files.zip Ben Miller, 2016-11-10 10:29 PM

Related issues

Related to CUNY Academic Commons - Feature #6752: Modifications to RePort_Bot shortcodeResolved2016-11-15

History

#1 Updated by Boone Gorges almost 3 years ago

  • Status changed from New to Reporter Feedback
  • Assignee set to Boone Gorges
  • Target version set to Not tracked

Iframes are the easiest solution for displaying the content. You'd probably want an iframe with an "open in new window" link, since the iframe will be small. I'd need to create shortcodes for you, since raw iframe code is not permitted for non-admins.

Embeds require that the embed source remain available indefinitely, which may not be a good bet in either or both of these cases. If, in addition to display, you need to preserve or archive the sites, I'd suggest taking HTML snapshots of each site. http://www.httrack.com/ seems like a good tool. This may not successfully fetch content stored on YouTube, but it should get all other content.

If you decide to archive the sites, there's a further question as to whether it's best to show the archived site in the JITP iframe, or the original. You presumably do not have direct control over the originals, such that the owners could change them at any time. This may be good in some cases (fixing typos, etc) but could be bad in others (vandalism, content that is changed so that orignial critique is no longer relevant, etc). If you decide that you want the archived version to show in the JITP iframe, you'll need to transfer the static site snapshot to me, so that I can load it into the Commons.

If we decide to go with the iframe suggestion, it would probably be best to have a specific theme template file for showing the iframe. The external content will look best when it's wide, which suggests that you'll want a template without sidebars. This part is optional and totally up to you, of course.

Alternatively, it's probably possible to extract the plaintext content of one or both of the sites and import it into the Commons. But this will surely take at least some custom scripting, so is likely to require much more work than an iframe embed.

Let me know how you'd like to proceed. Assuming you go with iframes, I'll need to know how and from where the iframe source will be served before creating the shortcodes.

#2 Updated by Stephen Klein almost 3 years ago

Question: could the JITP space on the Commons just have a subdirectory to place standalone html and other files?

#3 Updated by Boone Gorges almost 3 years ago

If you decide to go with the iframe method, then yes, what I'll essentially be doing is setting up a directory for JITP static assets. However, for reasons related to security and workflow, it's not possible for me to allow JITP admins to manage this space themselves - the assets would have to go through me.

#5 Updated by Boone Gorges almost 3 years ago

The static sites will be standalone. iframe is just a protocol for viewing the sites within the context of another page (ie, JITP's site).

#6 Updated by Stephen Klein almost 3 years ago

great, because we MIGHT NOT go with iframe.

#7 Updated by Luke Waltzer over 2 years ago

@Boone-- just wanted to let you know both of these pieces are on schedule to be finalized on or around Nov 1. We'll deliver one to you as a full directory (it will look like the GDrive directory in the original post), and the other will be hosted externally at http://teachmix.com/ilit/. We'll go with the iFrame option for both; @Stephen will advise on our strategy for archiving, but it shouldn't impact your workflow.

JITP's default post template is already full-width, and there are some other post templates in the theme that we can use if we need to. If possible, can you please share a sample iFrame shortcode (preferably one that displays a directory with its own internal navigation) so we can plug into our dev site to see if there are any glaring issues with the design?

Thanks!!

#8 Updated by Stephen Klein over 2 years ago

Other than insuring that robots.txt does not exist or is modified to allow for a crawl nothing probably needs to happen at first to allow for an Archive-It crawl. However, I will know more after a test crawl.

#9 Updated by Boone Gorges over 2 years ago

Here's an example of one of your existing iframe shortcodes running in a full-width template: https://jitpdev.commons.gc.cuny.edu/?page_id=3782&preview=true

We'll go with the iFrame option for both; @Stephen will advise on our strategy for archiving, but it shouldn't impact your workflow.

If I understand this correctly, the one that you'll be delivering to me will be hosted and served from the Commons, while the other will be hotloaded from teachmix.com. Let me know if I've got this wrong.

#10 Updated by Luke Waltzer over 2 years ago

Boone-- we're in copyediting and staging now, and would like to move forward with some tests through the end of the week if you could help us.

We're now looking at three pieces that need special attention.

1. More than Assessment: What ePortfolios Make Possible for Students, Faculty, and Curricula, by Bartlett

This is a full html site. The directory needs to be loaded onto the Commons, and an iFrame needs to be created to embed it here: https://jitpstaging.commons.gc.cuny.edu/wp-admin/post.php?post=3755&action=edit

I've attached the penultimate draft of the submission -- it's still going through copyediting, but we would like to test the display sooner than later. Possible to post directory now, and swap in any edited files after copyediting? I've attached the full directory as a zip.

2. I Lit: An E-Poetry, E-Portfolio Exhibit, by Anderson and Shephard

This is an external Drupal site. Author has offered to help with transfer to our servers, but I think an iFrame embed from current server is preferable at least for the short term. Site is here: http://teachmix.com/ilit/. Staging post is here: https://jitpstaging.commons.gc.cuny.edu/wp-admin/post.php?post=3760&action=edit

I Lit is completed and ready to stage..

3. RePort_Bot: A Computational Approach to ePortfolios and Reflection, by Omizo

In this piece, we're looking to embed 3 interactive images from this page: http://rmomizo.github.io/RePort_Bot/report as full-column interactive images within the body of the text. At this point, we just need to know if it's possible to do so. The images are: h-Point for total pages http://ryan-omizo.com/ ('first', (13, 13)); ryan-omizo.com | h-point (u'writing', (2, 2)); and Research h-point (u'graph', (2, 2)).

Link to post on staging is here -- https://jitpstaging.commons.gc.cuny.edu/wp-admin/post.php?post=3753&action=edit -- though there's not yet text in it.

If it’s helpful, here’s the repo for the Report Bot: https://github.com/rmomizo/RePort_Bot

Please let us know if you need any other information, especially on that last one.

Thx,
Luke

#11 Updated by Boone Gorges over 2 years ago

  • Target version changed from Not tracked to 1.9.32

More Than Assessment added in https://github.com/cuny-academic-commons/cac/commit/ffad865055a9b67e1de0bf8c376fad34aad86c31

Usage: [jitp-morethanassessment]. Accepts height and width params.

RePort_Bot shortcodes added in https://github.com/cuny-academic-commons/cac/commit/e451895e162bdfe40d04262dba60e14d9167e18f. This required wrapping the JS and handling dependencies in a specific way to account for multiple images appearing on a page. I believe it's working properly, but this'll need verification after the release later today.

Usage: [jitp-reportbot-first], [jitp-reportbot-writing], [jitp-reportbot-graph]

Embedding the I Lit project in an iframe is going to pose a problem due to browser security policies. http://teachmix.com/ilit/ doesn't have an SSL cert associated with it. So browsers will throw a fit and not display the content if viewing JITP over SSL. Four possible solutions:
1. Get an SSL cernt for teachmix.com. They are free from letsencrypt.
2. Get me a static dump of the Drupal site, which I'll host as HTML, using Commons certificates
3. Force this specific JITP page to be non-secure.
4. Live with the security warnings, and instruct visitors to manually add an exception to browser policies.

These are listed in order of my preference. An SSL cert for teachmix is definitely the best option, though I don't know who the domain belongs to. I'd consider 3 only as a last resort. Luke, do you have thoughts?

#12 Updated by Stephen Klein over 2 years ago

I prefer option 2. Luke?

#13 Updated by Luke Waltzer over 2 years ago

Thanks, Boone. I've asked that the author encrypt the site, which creates the lowest immediate burden on Boone. Stephen, I agree though that the static dump would be beneficial for archiving purposes. Do you want to follow up, via Amanda, with that as an additional request.

#14 Updated by Stephen Klein over 2 years ago

Not embracing #2 just for archiving purposes, but because, more importantly, it is the simplest and biggest bang for the buck.

#15 Updated by Boone Gorges over 2 years ago

  • Target version changed from 1.9.32 to 1.10

Thanks, gentlemen. 1.9.32 will include the [jitp-ilit] shortcode for your testing purposes. It's SSL-sensitive: if you use it on http://jitp..., it'll request the non-SSL version, which will work; if you use it on https://jitp..., it'll request the SSL version, which will not. If the certificate gets set up, then things will automatically fall into place on the JITP site. I'll leave this ticket open against the next milestone so that you can update me about any bugs or any movement on a static archive.

#16 Updated by Luke Waltzer over 2 years ago

Boone Gorges wrote:

RePort_Bot shortcodes added in https://github.com/cuny-academic-commons/cac/commit/e451895e162bdfe40d04262dba60e14d9167e18f. This required wrapping the JS and handling dependencies in a specific way to account for multiple images appearing on a page. I believe it's working properly, but this'll need verification after the release later today.

Usage: [jitp-reportbot-first], [jitp-reportbot-writing], [jitp-reportbot-graph]

Thanks so much, Boone. Looks like the Report Bot short code is placing the images above all text in the post rather than where the shortcode call is listed : http://jitpstaging.commons.gc.cuny.edu/report_bot/ (path to edit post: https://jitpstaging.commons.gc.cuny.edu/wp-admin/post.php?post=3753&action=edit

Any suggestions?

#17 Updated by Boone Gorges over 2 years ago

Shoot, I was echoing a value where I should have been returning it. I've just put a fix in place. Can you verify?

#18 Updated by Luke Waltzer over 2 years ago

That does it; u rule.

#19 Updated by Ben Miller over 2 years ago

Agreed! Thanks, Boone!

I have a question about the iframe at http://jitpstaging.commons.gc.cuny.edu/more-than-assessment/. When we set the width to match our usual content column, the last navigation button within the frame (References) gets partially obscured by a div#embed, so that only half the button is clickable. (Screenshot attached.) Can either of you tell if that's coming from the shortcode or the original file? Is there an easy fix to z-index or something else that would preserve whatever function it's supposed to serve, but also leave the nav accessible? And if so, is it something we can/should do from our end?

Also, can I just confirm that we can't use responsive width (e.g. width=100%) with the shortcode? The theme of the source site is mobile-ready, but if we declare a fixed width on the iframe, the inner @media still thinks it's at 960px, even when the JITP site gets narrow. But if we're stuck, we're stuck.

#20 Updated by Boone Gorges over 2 years ago

Hi Ben -

The element that's laid over your content comes from our Zendesk integration. Since you're hiding the admin bar on JITP, you may as well hide this element too, for an easy fix. Something like this should work:

.zEwidget-ticketSubmissionForm { display: none; }

Since you're already managing the (non-)appearance of the admin bar, it probably makes sense for you to do this in the same way. I've added Ray here (who is in charge of our Zendesk integration) as an FYI.

Also, can I just confirm that we can't use responsive width (e.g. width=100%) with the shortcode? The theme of the source site is mobile-ready, but if we declare a fixed width on the iframe, the inner @media still thinks it's at 960px, even when the JITP site gets narrow. But if we're stuck, we're stuck.

I've just hardcoded width="100%" for this shortcode. Can you verify that it's what you want? It's much easier for me to hardcode than for me to allow you to enter either a numeric value or a percentage (validation gets more complex) so if I could leave it as a hardcoded value, it makes my life easier.

#21 Updated by Ben Miller over 2 years ago

Thanks, Boone! I'll add that display:none to our stylesheet.

As for the hardcoded width=100%, it looks great to me, and will let us make whatever adjustments we want to the text column width later, without having to update the iframe. If there are no objections from Stephen or Luke, I'd be happy to go with that, and the same for [jitp-ilit]. (The editors are checking with the author about getting the SSL certificate.)

#22 Updated by Boone Gorges over 2 years ago

Sounds good, Ben. I've hardcoded 100% for each iframe. Let me know if you need changes.

#23 Updated by Luke Waltzer over 2 years ago

@Boone The I Lit project has been moved to a new url (where an SSL cert is in place). Could you please change that iFrame to pull from https://ilit.altscholarship.com/

Thx-

#24 Updated by Boone Gorges over 2 years ago

  • Status changed from Reporter Feedback to Assigned
  • Target version changed from 1.10 to 1.10.1

I'll make the change in the next day or two.

#25 Updated by Boone Gorges over 2 years ago

  • Status changed from Assigned to Reporter Feedback

The URL change is in place on jitpstaging - can you verify please?

#26 Updated by Ben Miller over 2 years ago

Confirmed that the iframe works well at https://jitpstaging.commons.gc.cuny.edu/i-lit/. Thanks, Boone!

#27 Updated by Ben Miller over 2 years ago

Luke had written:

1. More than Assessment: What ePortfolios Make Possible for Students, Faculty, and Curricula, by Bartlett [...] Possible to post directory now, and swap in any edited files after copyediting? I've attached the full directory as a zip.

We've now got the files back from copyediting, relevant to this shortcode:

More Than Assessment added in https://github.com/cuny-academic-commons/cac/commit/ffad865055a9b67e1de0bf8c376fad34aad86c31

Usage: [jitp-morethanassessment]

The updated files are attached as a zip. Would you be able to swap these in, Boone?

#28 Updated by Boone Gorges over 2 years ago

Sure, I will add them. But the files appear to be identical, except for the addition in the new zip of a new .docx file. Is that correct?

#29 Updated by Ben Miller over 2 years ago

Wow, thanks for catching that! It's on me: I apparently grabbed the wrong "Bartlett revised" zip, since I apparently have four stages of them in that directory. Please use this one instead.

My apologies to everyone listening.

#30 Updated by Boone Gorges over 2 years ago

  • Status changed from Reporter Feedback to Resolved

Thanks, Ben.

These files have been updated in the 1.10.x branch https://github.com/cuny-academic-commons/cac/commit/3ca8e981b5d32f970f80c649d1a312deb4ca0013

It'll be part of the 1.10.1 release, coming shortly. For other issues, let's open a new ticket against a future milestone.

#31 Updated by Ben Miller over 2 years ago

Thanks, Boone! We really appreciate your making all this possible, including the rapid responses.

#32 Updated by Luke Waltzer over 2 years ago

Boone-- looks like we need one more interactive image available as an iFrame for the RePort_Bot piece.

The image is the treemap for "Teaching" h-point (u'writer', (3, 3)) listed 4rd here: http://rmomizo.github.io/RePort_Bot/report

Think it's possible to deploy another iFrame for this in next couple of days? We're looking to launch on Monday.

Thx-

#33 Updated by Boone Gorges over 2 years ago

  • Related to Feature #6752: Modifications to RePort_Bot shortcode added

#34 Updated by Boone Gorges over 2 years ago

I've added a new ticket to track the request: https://redmine.gc.cuny.edu/issues/6752

Also available in: Atom PDF