Project

General

Profile

Bug #5886

"Recent Posts" Activity Stream Ferkakte

Added by Luke Waltzer about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
Home Page
Target version:
Start date:
2016-08-11
Due date:
% Done:

0%

Estimated time:

Description

"Recent Posts" on the front page of the Commons is showing a post from January that I recategorized yesterday, but not the two posts that I posted today (both logged in and out, Chrome/Safari/FF).

Also, when I click on Recent posts, I go to commons.gc.cuny.edu/blogs redirects to https://commons.gc.cuny.edu/groups/cuny-wide-composition-and-rhetoric/forum/topic/blogsbaruch-422-630pm/. Now I know all paths lead to Blogs@Baruch... but I'm doubtful this is expected behavior.

/groups and /members seems to be working correctly.

History

#1 Updated by Matt Gold about 5 years ago

Oy!

#2 Updated by Boone Gorges about 5 years ago

  • Category name set to Home Page
  • Status changed from New to Resolved
  • Assignee set to Boone Gorges
  • Target version set to 1.9.24

"Recent Posts" on the front page of the Commons is showing a post from January that I recategorized yesterday, but not the two posts that I posted today (both logged in and out, Chrome/Safari/FF).

The BP Widget Cache plugin was activated on the main Commons site, but not network activated. As a result, invalidation wasn't running properly when publishing a new post, and the widget was serving stale content. This is probably my fault - I've occasionally toggled this plugin, and I probably did it wrong - but I'm copying Ray here in case it was his fault ;)

Also, when I click on Recent posts, I go to commons.gc.cuny.edu/blogs redirects to https://commons.gc.cuny.edu/groups/cuny-wide-composition-and-rhetoric/forum/topic/blogsbaruch-422-630pm/. Now I know all paths lead to Blogs@Baruch... but I'm doubtful this is expected behavior.

Fixed in https://github.com/cuny-academic-commons/cac/commit/0bf0bbd41c8bea905eb9b23bdfd67df049d5b824

Also available in: Atom PDF