Project

General

Profile

Bug #5890

Commons user profile erroneously indicates a group for a member

Added by Matt Gold about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Commons Profile
Target version:
Start date:
2016-08-11
Due date:
% Done:

0%

Estimated time:

Description

I'm looking at a member with my admin account and it shows that the member is part of one group. When I clicked on "Groups," though, there were no groups to be found. Not sure whether this has to do w/my admin view or not, though. Please see the attached screenshot

http://commons.gc.cuny.edu/members/smalhotra/?commons-profile=1

History

#1 Updated by Boone Gorges about 5 years ago

  • Status changed from Assigned to Resolved
  • Target version set to 1.9.24

The 1 here represents a pending group invitation for the user. It was introduced in https://github.com/cuny-academic-commons/cac/commit/adce320b13ce8687cf4f78e3826fa52c84772b2f, along with a similar count for the Friends nav item, as part of #4210. The issue is that this modification should only happen when viewing one's own profile.

Fixed in https://github.com/cuny-academic-commons/cac/commit/94b1f760ad179462c4dd993ea5aad2aa4d6746db

Also available in: Atom PDF