Project

General

Profile

Actions

Bug #5969

closed

Queens students unable to join

Added by Marilyn Weber about 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Registration
Target version:
Start date:
2016-08-30
Due date:
% Done:

0%

Estimated time:

Description

I now have two reports that users with the email suffix @QMAIL.CUNY.EDU are unable to join.

Last year, I collected the undergrad email conventions. Is it possible that these suffixes were blacklisted? Or could this be something else?

Actions #1

Updated by Matt Gold about 6 years ago

Thanks, Marilyn. Now that we are allowing undergrad classes, we probably need to remove the restrictions on undergrad email registrations that we instituted previously.

Actions #2

Updated by Boone Gorges about 6 years ago

  • Status changed from New to Reporter Feedback

The restrictions on undergraduate domains have already been removed. See #5237.

Marilyn, you described the domain as being in all caps. Is this coming directly from your reports? If so, the capital letters could be the problem; it appears that the JS that checks for validity is OK with qmail.cuny.edu but not QMAIL.CUNY.EDU.

Also, could you provide any additional details about what "unable to join" means? Does it mean that the Register page asked them for a signup code after they entered their email address? Or something else?

Actions #3

Updated by Matt Gold about 6 years ago

Boone Gorges wrote:

The restrictions on undergraduate domains have already been removed. See #5237.

Thanks, Boone.

Actions #4

Updated by Marilyn Weber about 6 years ago

It just so happens that I too am a Queens College grad student this semester, so I just activated my account and joined the Commons myself. I had no hiccups whatsoever. Boone, I will try to find out what happened with these students but I don't think this merits any more of your attention for now.

Actions #5

Updated by Boone Gorges about 6 years ago

  • Status changed from Reporter Feedback to Rejected

Sounds good - thanks, Marilyn. Definitely let me know if this needs my attention.

Actions #6

Updated by Marilyn Weber about 6 years ago

Two more students are reporting problems today. I have asked them both to provide more information and to let me know if they are using all caps. Is there any way that the JS that checks for validity could accept QMAIL.CUNY.EDU? If so, would it have a problem with partial capitalization, like Qmail.Cuny.edu? I, for one, do tend to capitalize that Q for emphasis.

Actions #7

Updated by Matt Gold about 6 years ago

Hi Marilyn

Can you please check Unconfirmed to see if they show up there? I think we gave you access last semester. Thank you

Actions #8

Updated by Marilyn Weber about 6 years ago

The latest student who complained does show up there - . But her "time Registered" is in the future - 2016-09-01 19:22:57. Could that be a problem?

Actions #9

Updated by Marilyn Weber about 6 years ago

The third reporter - - does not show up in unconfirmed at all.

The second and first  are now fully registered, but neither updated me so I don't  know what their problems actually were.
Actions #10

Updated by Marilyn Weber about 6 years ago

The third reporter - - entered the wrong email. So the only mystery now is .

I received my Qmail confirmation right away.

Actions #11

Updated by Boone Gorges about 6 years ago

  • Category name set to Registration
  • Status changed from Rejected to Resolved
  • Assignee set to Boone Gorges
  • Target version set to 1.9.27

As it turns out, the only part that was case-sensitive in this specific case was 'cuny.edu'. So Qmail.cuny.edu would have worked, but QMAIL.CUNY.EDU would not. I've fixed this in https://github.com/cuny-academic-commons/cac/commit/de1aa0e928b21e63cd44444bb9042aaa0ce3a45a. The fix will be available in the next release on the 11th.

Actions

Also available in: Atom PDF