Project

General

Profile

Bug #6101

Profile update problems

Added by Marilyn Weber about 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
Public Portfolio
Target version:
-
Start date:
2016-09-28
Due date:
% Done:

0%

Estimated time:

Description

Steve Brier reports "Though I type in changes and additions to my Profile after clicking the "Edit Profile" button and then click "OK" and "Save" to save them, the changes aren't there when I check my Public Profile. Not sure what I'm doing wrong. I've tried it 2 or 3 times without success."

He clarifies that this is in the Widget fields at the bottom, and he is trying to add his resume/CV. He will send me a screenshot later today. In the meantime, does this ring any bells?

History

#1 Updated by Boone Gorges about 5 years ago

No specific bells. This could be any of a number of things. Screenshots would be helpful, as would a full copy of the text that he's trying to add to the widget.

#2 Updated by Boone Gorges about 5 years ago

  • Category name set to Public Portfolio
  • Status changed from New to Reporter Feedback
  • Assignee set to Boone Gorges
  • Target version set to Not tracked

#4 Updated by Marilyn Weber almost 5 years ago

I cannot replicate it.

#5 Updated by Boone Gorges almost 5 years ago

Thanks, Marilyn. Could you please ask Steve to provide the full text he's attempting to add here? It's likely that there is a character-encoding issue, which is hard to debug without the actual text in hand.

#6 Updated by Marilyn Weber almost 5 years ago

He replies:

What I was attempting to insert under the “BOOKS” section of my C.V. was the following new entry:

  • [this is the asterisk symbol on the keyboard, which is what I used in the other entries] Co-author (with Michael Fabfricant), Austerity Blues: Fighting for the Soul of Public Higher Education (Johns Hopkins Univ. Press, 2016).

Note that I also tried deleting words in the other entries and that didn’t “stick” either when I saved it.

#7 Updated by Marilyn Weber almost 5 years ago

Boone, I asked Steve:
Are you typing this in or cut/pasting from Word? Thanks!

He replied:
Typing it in into the screen shots that I sent

Boone, so I just tried typing an asterisk and it worked fine. Could this possibly have anything to do with the length of his entry? His publications field is wordy. Here's a link - https://commons.gc.cuny.edu/members/sbrier/

#8 Updated by Marilyn Weber almost 5 years ago

Now we have another Zendesk user who writes: " I can click the Publications widget and it opens up. But then when I insert my pubs, click OK, and then click “save changes,” no publications section appears in my profile."

#9 Updated by Matt Gold almost 5 years ago

FYI -- another report:

Matthew
Nov 8, 2:07 PM EST

Matthew was not signed in when this comment was submitted. Learn more[support.zendesk.com]
I am trying to add spaces between the entries under "conference presentations." I add the spaces, but it does nothing in the display...

------------------
Submitted from: https://commons.gc.cuny.edu/members/knipm/

#10 Updated by Boone Gorges almost 5 years ago

  • Target version changed from Not tracked to 1.10.1

After some debugging, it appears that the problem (Steve's problem, at least) is poorly encoded linebreaks, most likely being pasted from MS Word or another such word processor. I've got a temporary fix in place that appears to address this specific issue.

Marilyn, can you have Steve verify?

I'm unsure whether this will address the problems described by other users, without more details. Perhaps we could ask them to see whether the current fix has cleared things up for them, and if not, to provide us with more details (URL, specific text that's being updated, screenshots, etc).

#11 Updated by Matt Gold almost 5 years ago

Thanks so much, Boone

#12 Updated by Marilyn Weber almost 5 years ago

I'm sorry to say I have another report of this problem.
User Jeremy Sawyer writes:
"When I try to edit my CUNY Commons public profile, after reading the tutorial, I press one of the grey "widgets" to add Education or Publications. I enter my information in the appropriate box, then save with the button near the widget. Next, I also "save changes" at the bottom of the page as instructed. The page then returns to my public profile view, but the widget is never added to my public profile, no matter how many times I save. Can you please help?"

Steve Brier reported his problem as solved, but I still have two open tickets about this. I wrote to them at the same time I wrote to Steve, but I haven't heard back yet. Matt Brim (https://commons.gc.cuny.edu/members/mattbrim/) describes exactly the same problem as Jeremy. Matthew Knip (https://commons.gc.cuny.edu/members/knipm/) already has a publications section, but he cannot correctly format any new information.

I've asked all three to clarify whether they are typing in the information or cut and pasting. I've asked both the Matts to try again. I cannot replicate this problem myself. Let me know what more I can ask them, Boone.

#13 Updated by Boone Gorges almost 5 years ago

Thanks for the update, Marilyn. It's good to hear that Steve's probably appears to be resolved.

I've just done test edits on the profiles of all three members you've listed (jeremy, mattbrim, knipm), and in each case, the edit worked as expected. So, in each case, the problem must be due to either (a) some specific issue with the content that's being entered, or (b) some aspect of the user's environment that's different from what you and I are testing with.

If the users report that they're still having the issue, it would be helpful to have the following details:
1. Browser and operating system name and version (for example: Windows 10.1, Firefox 49.0.2)
2. The specific content that users are trying to input, or in the case of editing, the exact edits that are triggering the unsaved profiles
3. If possible (ie if you think this would not be a terrifying experience for the user) the user should open the browser's JS console to see if there are any errors when editing, clicking "OK", or clicking "Save Changes"

#14 Updated by Boone Gorges almost 5 years ago

  • Target version deleted (1.10.1)

The fix for Steve's problem is in https://github.com/cuny-academic-commons/cac-advanced-profiles/commit/2cb0280f5bcdd0e7016810cffb7704774ce84d16 and will be part of the 1.10.x release.

I'm going to move this out of the milestone until we have a clearer sense of what's going on with the other users.

#15 Updated by Matt Gold almost 5 years ago

  • Priority name changed from Normal to High

#16 Updated by Marilyn Weber almost 5 years ago

Matt Brim reports the following fix:
I just tried it on my Ipad and it worked. So the browsers on my PC weren’t working, but the ipad interface did allow me to make updates, fyi.

Pressing Matthew Knip and Jeremy Sawyer for replies.

#17 Updated by Boone Gorges almost 5 years ago

Hi Marilyn - Did you ever hear back from the other reporters? I wonder if we might mark this one resolved.

#18 Updated by Marilyn Weber almost 5 years ago

Matthew Knip said it's resolved; Jeremy Sawyer never replied.

#19 Updated by Boone Gorges almost 5 years ago

  • Status changed from Reporter Feedback to Resolved

Thanks, Marilyn. Let's tentatively mark resolved.

Also available in: Atom PDF