Project

General

Profile

Bug #613

Member reports group blog / group member syncing

Added by Matt Gold over 11 years ago. Updated over 11 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2011-02-24
Due date:
% Done:

0%

Estimated time:

Description

"When I deactivate then reactivate the Living Lab blog, it still doesn't include all of the new group members. This had worked before."

http://commons.gc.cuny.edu/groups/livinglab/admin/group-blog

The member is using instructions based on this help blog post: http://help.commons.gc.cuny.edu/2010/09/01/how-to-let-new-members-of-your-group-post-to-the-group-blog/


Related issues

Related to CUNY Academic Commons - Bug #625: BP Groupblog not correctly syncing with BP member blog listsResolved2011-02-28

History

#1 Updated by Matt Gold over 11 years ago

Just confirmed that the "normal" process of syncing (unchecking "enable group blog" from group interface, saving, rechecking checkbox) isn't working.

what's strange is that the user listing on the blog dashboard shows a total of 27 members, which makes sense that there are 27 members in the group. BUT, when you look at the number of members by role, it adds up to 21, not 27.

I'm wondering whether this might be due, perhaps, so some kind of limit placed on the number of people who can be added to a blog?

I can add them manually, but this seems like a bug, so we should check it out.

#2 Updated by Matt Gold over 11 years ago

Another note: some members of the group who are not listed as users on the blog have member profiles that, weirdly, show membership in the blog.

Example:

This member: http://commons.gc.cuny.edu/members/scheng/blogs/ shows the Living Lab blog in her profile, but she's not actually listed among its users in the dashboard of the blog.

#3 Updated by Boone Gorges over 11 years ago

  • Status changed from Assigned to Reporter Feedback

Clarification: Toggling 'Enable group blog' is not intended to reset blog membership. In fact, when you uncheck 'Enable group blog' and save your changes, the Groupblog plugin deletes your settings from the second half of the Group Blog group admin page.

What will resync blog/group membership is if you toggle 'Enable blog member posting', the second checkbox on the admin panel. Please test to ensure that I'm correct about this.

Matt, the issue of BP member blog lists being out of sync is separate from this one. Please open another ticket.

#4 Updated by Boone Gorges over 11 years ago

Also, I meant to point out that the bold-faced note at the bottom of http://help.commons.gc.cuny.edu/2010/09/01/how-to-let-new-members-of-your-group-post-to-the-group-blog/ is no longer correct. That was a bug that should have been fixed in Commons 1.1.9. See http://redmine.gc.cuny.edu/issues/show/546. Please verify, and update the codex accordingly.

#5 Updated by Matt Gold over 11 years ago

Matt, the issue of BP member blog lists being out of sync is separate from this one. Please open another ticket.

I'm confused -- the lists being out of sync was the bug reported in the ticket. What is the other issue you're thinking is the main subject here? The instructions on how to sync group and blog? If so, I'd say that that's what should go in a separate ticket.

#6 Updated by Boone Gorges over 11 years ago

The list of blogs that appear under a user's profile is, contrary to what you might think, totally independent of a user's blog permissions. The problem being reported in this ticket is, I presume, that group members do not actually have permission to post on the group blog, not that the group blog isn't appearing at commons.gc.cuny.edu/members/[member-name]/blogs The former is, I'm suggesting, not a bug. The latter is a bug, but separate from this one.

Never mind though, I'll open it myself.

#7 Updated by Matt Gold over 11 years ago

Okay -- thanks. The main bug I meant to report here is that our established methods of syncing group/blog memberships isn't working in this case. I did indeed try toggling 'Enable blog member posting', with unsuccessful results. Please let me know whether you have better luck.

I take your point about the blog listing in a member's profile, but what still strikes me as strange is the indication of 27 users in the blog dashboard while only having 21 listed.

#8 Updated by Boone Gorges over 11 years ago

I take your point about the blog listing in a member's profile, but what still strikes me as strange is the indication of 27 users in the blog dashboard while only having 21 listed.

Can you explain what that means?

#9 Updated by Boone Gorges over 11 years ago

I did indeed try toggling 'Enable blog member posting', with unsuccessful results. Please let me know whether you have better luck.

Works for me. After rechecking, you'll find that you have to reset the preferred roles for group members/mods/admins. That's the part that actually triggers the resync.

#10 Updated by Matt Gold over 11 years ago

Here's what's strange: now the blog dashboard shows 32 total users but still only lists 21. When you check the blog authors list from the BP Admin bar, it shows 28.

#11 Updated by JR Rosen over 11 years ago

To explain a bit and also point out how I can see there's something strange:

In Users, I have All (33), Administrators (4) Authors (13) Subscribers (4).

That clearly doesn't add up. Although the number listed in All has changed, the other three numbers haven't, nor has the list of users.

When I search for a user on that page, I get their avatar and info if and only if they are one of the users listed on the page. When I search for someone I believe to be in that missing group, I get no search results, or, rather, nothing shows up between the header and footer of the search results--there is no space even between the header and footer. When I search for someone I know won't be there, it tells me in a red/pink box that "No matching users were found!" Clearly there are users that are invisible!

jrr

#12 Updated by Boone Gorges over 11 years ago

  • Status changed from Reporter Feedback to Resolved

I did some experimentation on the live site, and I was able to refactor the groupblog code to make the sync work correctly. Fixed in https://github.com/castiron/cac/commit/eba02d14fae82120049e26eb5455d4b289b9e003

Jody - The Living Lab group and blog are now in sync. However, if you attempt to resync before I roll out Commons 1.1.10 (probably on Tuesday), you'll find that it won't work. So be patient :)

Note that this also appears to fix the problem in #625, as my new method of adding/removing users from blogs fires the correct hook to sync BP's blog data.

#13 Updated by Matt Gold over 11 years ago

Great work, Boone -- thank you.

Also available in: Atom PDF