Project

General

Profile

Feature #615

"Enter" should trigger autocomplete event

Added by Matt Gold over 10 years ago. Updated almost 5 years ago.

Status:
Rejected
Priority name:
Low
Assignee:
Category name:
BuddyPress (misc)
Target version:
-
Start date:
2011-02-24
Due date:
% Done:

0%

Estimated time:

Description

A member reports that when she hits enter after typing a members name in the search box on the send invites screen, nothing happens. Just beginning the process of typing, however, does bring up names.

History

#1 Updated by Boone Gorges over 10 years ago

  • Priority name changed from Normal to Low

What is the problem here? What's the expected behavior?

#2 Updated by Matt Gold over 10 years ago

Expected behavior is that it would do an ajaxy search through user accounts and pop up the account of the name searched for. The user's point is that we're used to hitting "enter" when typing into a search box, and that if the ajax interface is delayed, as it sometimes is, in popping up names as one types, the user may hit enter. If the act of hitting enter doesn't actually perform a search, the user gets confused.

I hope that's clear -- let me know if it's not. I'm still unsure whether or not I agree that this is a problem, but I am trying to articulate the user's perspective.

#3 Updated by Boone Gorges over 10 years ago

  • Target version changed from 1.1.10 to 1.3

I think that the way that the search currently works is on a keyup delay - it sends the search request when you stop typing for, maybe, 2 seconds.

I don't have a problem adding enter to the list of search triggers, but this will require rewriting parts of the autocomplete interface. In truth, I have a goal of rewriting this altogether so that it is more efficient and can be better applied through BP. But this is too big a job for the time being.

Unless someone objects that this is a major problem requiring immediate attention, I am going to push it to a later milestone.

#4 Updated by Boone Gorges over 10 years ago

  • Subject changed from Search Box Changes on Send Invites Interface to "Enter" should trigger autocomplete event

#5 Updated by Matt Gold over 10 years ago

No objection at all. That makes sense given more pressing priorities.

#6 Updated by Boone Gorges over 10 years ago

  • Target version changed from 1.3 to Future release

AJAX autocomplete in BuddyPress is in the middle of an overhaul. I'm going to punt this ticket until that overhaul is done, so that our efforts can be better spent.

#7 Updated by Matt Gold over 10 years ago

Okay. thanks.

#8 Updated by Boone Gorges almost 5 years ago

  • Status changed from Assigned to Rejected
  • Target version deleted (Future release)

Revisiting this, the flow works as follows:

1. You start typing
2. On keyup, search begins immediately as long as you have typed at least 3 characters
3. There's an AJAX spinner indicating that a search request is taking place
4. Hitting enter does nothing, unless you have a single autocomplete result, in which case it selects that item

It seems to me that this is pretty good. Making Enter trigger an AJAX request doesn't make a lot of sense, given that we fire requests on keyup already. (It's likely that this behavior has changed since the ticket was opened.)

Also available in: Atom PDF