Project

General

Profile

Bug #6464

cac 1.10 Email notifications and reply by email testing

Added by Paige Dupont over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Email Notifications
Target version:
Start date:
2016-10-26
Due date:
% Done:

0%

Estimated time:

Description

The biggest bug I've found is the formatting of the emails. There is a duplication of data and it runs true for all email notifications as well as the notifications when comments are made to the respective platform.

A choppy run down:

When posting in the forum, email notifications show duplicated data (see screenshot 1). Reply by email is working fine.

When posting a file, email notifications show duplicated data (see screenshot 1) No reply by email.

When creating a paper, email notifications show duplicated data (see screenshot 1)
When updating a paper there seems to be a small glitch with the paragraph that had been updated (see screenshot 2).
There are no notifications when a "response" is made to a paper.
Reply by email for Papers notifications does not appear to be functioning.

There is no email notification for group announcements.
Also to note, there is also a tiny error when making a first announcement, the "no announcements yet" bar will not go away and this holds true even if you make multiple announcements. If you exit and come back to announcements, this goes away (see screenshot 3)

When creating a doc, email notifications show duplicated data (see screenshot 1)
When you post a new doc it doesn't follow the same conventions as a forum email notification. When posting a new doc, the title is shown but none of the content is shown which differs from posting a new forum topic. Forum post show the title and all of the forum content This is not true for Docs (see screenshot 4). However, I notice that this is also true for email notifications when a new Social Paper is created. Perhaps this was intentional?
Reply by email for Docs is not functioning. However, you can reply to a comment on the doc by email.

When creating an event, email notification show duplicated data (see screenshot 1)
There is no commenting on events which is slightly confusing only because of the View/Reply button that is standard in the email notifications.

Let me know if you have any questions about any of this! I hope it's useful.

Screen Shot 2016-10-26 at 12.11.15 PM.png (108 KB) Screen Shot 2016-10-26 at 12.11.15 PM.png Enjoy a snap of Dogatello for no reason Paige Dupont, 2016-10-26 12:38 PM
Screen Shot 2.png (70 KB) Screen Shot 2.png Paige Dupont, 2016-10-26 01:58 PM
Screen shot 1.png (108 KB) Screen shot 1.png Paige Dupont, 2016-10-26 01:58 PM
Screen shot 3.png (84.7 KB) Screen shot 3.png Paige Dupont, 2016-10-26 01:58 PM
Screen shot 4.png (119 KB) Screen shot 4.png Paige Dupont, 2016-10-26 01:58 PM
Rich Text.png (81.4 KB) Rich Text.png Stephen Real, 2016-10-27 09:56 AM
rbe.png (144 KB) rbe.png Stephen Real, 2016-10-27 09:56 AM
Double Emails 1.png (77.3 KB) Double Emails 1.png Paige Dupont, 2016-10-27 11:02 AM
Double Emails 2.png (81.2 KB) Double Emails 2.png Paige Dupont, 2016-10-27 11:02 AM
Missing Papers tab.png (127 KB) Missing Papers tab.png Paige Dupont, 2016-10-27 11:07 AM
Fail Message.png (15.6 KB) Fail Message.png Paige Dupont, 2016-10-27 11:27 AM
Posting a Doc comment.png (65.7 KB) Posting a Doc comment.png Paige Dupont, 2016-10-27 11:27 AM

History

#1 Updated by Boone Gorges over 3 years ago

  • Category name set to Email Notifications
  • Assignee changed from Boone Gorges to Raymond Hoh
  • Target version set to 1.10

Hi Paige - Thanks for the rundown. I think that a number of these are not bugs, but unimplemented features. Let me try to break them out:

When posting a file ... No reply by email.
Reply by email for Papers notifications does not appear to be functioning.
When you post a new doc it doesn't follow the same conventions as a forum email notification. When posting a new doc, the title is shown but none of the content is shown which differs from posting a new forum topic.
Reply by email for Docs is not functioning.

I think that none of these has been implemented. Several of them are good ideas, and probably warrant enhancement tickets.

A couple of issues might be cases where the email was intentionally withheld because we often don't send email notifications to the user who performed the activity. Can you verify that in each of the following cases, you were testing with a second email account?

There are no notifications when a "response" is made to a paper.
There is no email notification for group announcements.

The duplicate content issues, and the character encoding in screenshot 2, do appear to be legitimate bugs. Ray, could I ask you to have a look please?

#2 Updated by Raymond Hoh over 3 years ago

Ugh, apologies for this, Paige.

There were some plugins that needed to be deactivated before the new HTML emails could take effect properly on cdev.

Can you try again and let me know if you run into any other problems?

#3 Updated by Stephen Real over 3 years ago

I just tested a group forum post and some formatting issues on the original email and the rbe posted response. Screenshots are attached.

#4 Updated by Paige Dupont over 3 years ago

Raymond Hoh wrote:

Ugh, apologies for this, Paige.

There were some plugins that needed to be deactivated before the new HTML emails could take effect properly on cdev.

Can you try again and let me know if you run into any other problems?

Hey Ray,

No problem, I'll try again and get back to you.

#5 Updated by Paige Dupont over 3 years ago

Hey all,

I'm getting double notifications now from the testing environment and the normal CAC site? See Double Emails 1 and 2 png's below.

But the formatting looks good on the new notifications!

Also, I'm getting a weird thing with the left hand menu. the Papers tab keeps appearing and then disappearing (see missing papers tab png). The group has papers tied to it because I've just re-tested notifications for leaving a response on a paper and that is now working properly. See, "Missing papers tab png" After I found the paper by using the homepage nav. I was able to find and comment on my groups paper, THEN the tab reappeared in the left hand menu in my group.

When leaving a comment for a doc. I'm also hitting a tiny issue. When I try to leave a comment it sends me the fail message (See fail message png.) and then after refreshing the page will show the comment that the comment was posted. See (posting a doc comment png).

I did not realize that you had to select the button below a group announcement for the announcement to be sent to all of your group members. So maybe that was my problem with not receiving email notifications yesterday in regards to the announcements.

Other than that the previous issues I had from this ticket seem to be resolved.

#6 Updated by Boone Gorges over 3 years ago

Thank you, Paige!

Would you mind opening new tickets for the following?

1. Papers tab behavior
2. Duplicate message for Doc comment

I don't think they're 1.10 regressions, and in any case they're bound to get lost in the shuffle here.

Let's continue to use this ticket for 1.10 email notifications issues - maybe Ray will have some insight into why you got both a plaintext and an HTML notification of the same activity item.

#7 Updated by Raymond Hoh over 3 years ago

Stephen Real wrote:

I just tested a group forum post and some formatting issues on the original email and the rbe posted response. Screenshots are attached.

Sorry for missing this, Steve!

The underline issue is interesting because the Underline button is going to be removed from the Visual Editor in WordPress 4.7, so maybe we should follow suit?

If we want to keep the Underline button, let me know.

The second issue relating to RBE is more of a text-overflow issue with long text in the new HTML emails. I'll see what I can do here.

#8 Updated by Boone Gorges over 3 years ago

  • Target version changed from 1.10 to 1.10.1

Removing the underline button seems like a fine way around this. Let's do it for 1.10.1.

#9 Updated by Raymond Hoh over 3 years ago

Underline button removed in commit 886e534.

I'll leave this ticket open for any other issues related to email notifications for now. Or Boone, feel free to close.

#10 Updated by Boone Gorges over 3 years ago

  • Status changed from New to Resolved

Let's close and handle specific issues in separate threads. Thanks!

Also available in: Atom PDF