Project

General

Profile

Bug #6482

can 1.10 Events Test Issue

Added by Stephen Real about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Events
Target version:
Start date:
2016-10-27
Due date:
% Done:

0%

Estimated time:

Description

In testing the new Event paradigm of showing Events as Public if at least one of the groups it is associated with is public, I followed Boone's test script as follows:
1. Created event Trick or Treat in private group my test
2. Logged off and the event was not visible in site wide calendar
3. Logged in and edited event to associate it with public group Amazing Test Committee
4. Logged off and event was not visible in site wide calendar
5 Still logged off, I navigated to group Amazing Test Committee and clicked Events--I got a weird non-response screenshot attached.
Here is a link to the page I got http://commons.gc.cuny.edu/groups/test-group-1761529915/events/

Events.png (81.4 KB) Events.png Stephen Real, 2016-10-27 10:14 AM

Related issues

Related to CUNY Academic Commons - Bug #5717: Events not showing up on sitewide events calendarResolved2016-06-20

History

#1 Updated by Boone Gorges about 3 years ago

  • Category name set to Events
  • Assignee set to Boone Gorges
  • Target version set to 1.10

Hi Stephen - Thanks for the detailed report.

The event is showing up in the calendar of the public group (you seem to be getting a fatal error in the screenshot, but I can't reproduce?), but not on the sitewide feed.

I'll take a closer look.

#2 Updated by Boone Gorges about 3 years ago

  • Assignee changed from Boone Gorges to Raymond Hoh

I've done some testing. It seems that you have to edit the event twice to get the public status to stick. Here's what I was able to replicate:

1. Two groups: A is private, B is public
2. Create event in A. It's private, as expected.
3. Edit event and attach to group B.
4. Event is still private (this is the bug).
5. Edit the event again. Remove group B, and readd. Save changes.
6. Now the event is public (correct behavior).

I have only glanced at the bpeoToggle JS, but I'm guessing that maybe the initial toggle state is not being correctly recognized; or maybe it has to do with data being fetched via AJAX vs existing in the DOM when the page is loaded. Ray, can you have a look please?

#3 Updated by Boone Gorges about 3 years ago

  • Related to Bug #5717: Events not showing up on sitewide events calendar added

#4 Updated by Raymond Hoh about 3 years ago

Just to update that I plan to look at this in the next day or so.

Update - Time ran away from me, but I plan to look into this on the weekend before we launch 1.10 next week.

#5 Updated by Raymond Hoh about 3 years ago

  • Status changed from New to Testing Required

I've added a commit that should hopefully address this (view the following commit on the bp-event organiser repo - commit 1b0fcdb)

This can be tested on cdev.

#6 Updated by Boone Gorges about 3 years ago

  • Status changed from Testing Required to Resolved

This is looking great. I love the new message warning about public status when the event is linked to public and non-public groups. Thanks, Ray!

Also available in: Atom PDF