Project

General

Profile

Bug #657

Problems with WordPress Wiki Plugin

Added by Matt Gold over 11 years ago. Updated about 11 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2011-03-28
Due date:
% Done:

0%

Estimated time:

Description

Tonight, I activated the WordPress Wiki plugin on a blog and tried to turn a page into a wiki page. The plugin caused a bunch of problems and had some strange behaviors. Here's what I noticed:

-- The plugin altered the permalink of the page, putting it into a wiki/ directory.

-- There was no way to turn the wiki functionality off

-- The page originally had a parent page (this might have caused some problems vis-a-vis the new permalink). After turning it into a wiki page, I could find it on a drop-down under the parent page, even though the page was published. And when I clicked "view page" from the dashboard, I received an error message saying it didn't exist.

Scott, can you test out this plugin to see whether, in your view, it is working properly? It seems to me that, at the least, it's working very differently than it used to.


Related issues

Blocked by CUNY Academic Commons - Feature #659: Update WPMU Plugin StatsResolved2011-03-30

History

#1 Updated by Matt Gold over 11 years ago

  • Subject changed from Problems with WordPress Wiki Application to Problems with WordPress Wiki Plugin

#2 Updated by scott voth over 11 years ago

Hi Matt - I am confirming your suspicions - I couldn't get the plugin to work either, and had the same issue with it switching to wiki/ folder.

I checked the plugin's documentation at http://wordpress.org/extend/plugins/wordpress-wiki/ and found some pretty scathing comments, including "low quality," "works really badly," "hesitant to try," used to work but now doesn't, screws up my pages, would not recommend...

We are currently using version 1.0 of the plugin. I know I always steered away from this plugin because it made the "WIKI INC" plugin not work.

#3 Updated by Matt Gold over 11 years ago

Oy. I think we need to delete this plugin. Boone, do you agree? The sticky point is that we don't know who is using it (do we?). On the other hand, how can anyone be using it if it is so broken?

I used to use it and had no problems with it -- it worked very well.

#4 Updated by Boone Gorges over 11 years ago

  • Target version changed from 1.2 to 1.2.1

Yes, there is a way to see who's using it, but it's currently broken. See #659. That ticket will have to be fixed and live on the site before I can move forward, so I'm going to bump this to the next bugfix release.

BTW I wish more tickets revolved around removing rather than adding plugins :)

#5 Updated by Boone Gorges about 11 years ago

  • Assignee changed from scott voth to Boone Gorges

There are currently 17 blogs with the plugin activated.

It is going to be a royal pain in the ass to figure out what to do with them. For one thing, a recent update to the plugin means that all content needs to be run through a wizard (Dashboard > Settings > Wiki Options) to transfer to the new mode of content storage. Only then will we be able to tell who is actually using the plugin.

I think that the best course of action is for me to go through, manually upgrade all of the blogs, and then see how many of them are still actively editing wiki pages. Then I'll be able to see where to go next. Reassigning to myself, as the person who does this must be a super admin.

#6 Updated by Matt Gold about 11 years ago

Oy. Thanks for your work on this, Boone.

#7 Updated by Boone Gorges about 11 years ago

I ran some tests on my local machine, and the situation is not very good.

The plugin was recently upgraded to use custom post types for data storage. The problem is that the upgrade script included in the plugin does not appear to work correctly. I ran it on a blog where I knew that the plugin was in use, but it didn't properly move over any content to the new data type. Moveover, since the plugin was upgraded (many months ago, I think), the front-end editor wouldn't have worked anyway, unless users had manually run the upgrader (which no one appears to have done).

I browsed through the sites where the plugin is active, and none of them seem to have wiki pages in active use. So here is my suggestion for a solution: we simply remove the plugin. No content will be removed, because they are stored as regular WP pages/posts. Revision history will also be maintained. They just won't be editable in a wiki way anymore (from the front end).

We can research a different solution for wiki-type editing on WP blogs.

Feedback?

#8 Updated by Matt Gold about 11 years ago

Thanks for your work on this, Boone. I do want to note that the fact none of the sites with the plugin activated seem to be using it is a symptom of the break-down of plugin functionality. I can tell you, for instance, that I had activated and used the plugin on at least one blog. Here, for example, is a post that used to use it: http://digitalword.commons.gc.cuny.edu/2009/06/05/june-5-planning-meeting-notes/ (a note about that blog -- the theme on it appears to have been changed with one of our site upgrades. I can't remember what it used to use, but I know it wasn't TwentyTen.). So, in this case, at least, the plugin was in active use until it stopped working.

For this reason, I think that it might be worth contacting bloggers using the plugin to tell them about the situation and our proposed resolution. As you note, posts that used to have wiki functionality are now just regular posts, so it doesn't appear that any data will be lost -- just functionality that doesn't work anyway. But I do think that we should give people a heads-up on this, and I also think that this is the kind of thing we really should note on the Dev blog.

#9 Updated by Boone Gorges about 11 years ago

What I meant by "none of them seem to have wiki pages in active use" is that none of the blogs using the plugin seem to have been updated in many months or even several years. On those blogs, it's unlikely that anyone has noticed, or will notice, that the pages are no longer editable in a wiki-like fashion.

Here is a draft of the language.

Dear Commons blogger,

We have recently discovered problems with one of the WordPress plugins that you have used on the CUNY Academic Commons. Called WordPress Wiki, the plugin allowed front-end editing of blog posts in a wiki-like fashion. The plugin is currently activated on your blog [url].

The WordPress Wiki plugin has recently stopped working properly, and the Commons Dev Team has decided that it will be removed from the site. Here's what this means for you.

No content will be lost. Existing wiki pages on your blog will retain their content, as well as their revision history. These pages will still be available for reading, through the same URLs as before. The only change is that they will no longer be editable through the front end; all editing, and all browsing of the revision history, must happen through your blog's Dashboard.

We're sorry for any inconvenience that this change might cause. In the upcoming months, we'll be researching ways to bring back this wiki-like functionality to WordPress blogs on the Commons. To keep up on news related to development on the CUNY Academic Commons, visit http://dev.commons.gc.cuny.edu.

=

#10 Updated by Boone Gorges about 11 years ago

Also, I don't really understand the point about the blog theme. The blog you linked to does not use Twenty Ten, but a theme called PrimePress. If there is a real problem with unexpected blog theme switching, please open a new ticket with details.

#11 Updated by Matt Gold about 11 years ago

That's great, Boone. Thanks so much. Here's a slight re-draft to emphasize that the "stopped working properly" is not something that is our fault. Please feel free to re-edit. Man, we should have used BP Docs for this!! (though, actually, what we probably should have used is the "Documents" function here on Redmine)

Dear Commons blogger,

We have recently discovered problems with one of the WordPress plugins that you have used on the CUNY Academic Commons. Called WordPress Wiki, the plugin allowed front-end editing of blog posts in a wiki-like fashion. The plugin is currently activated on your blog [url].

The WordPress Wiki plugin no longer functions on current versions of WordPress, and its creators have halted development of it. Since the plugin isn't working and won't be updated, the Commons Development Team has decided to remove it from the site.

Here's what this means for you:

None of your content will be lost. Existing wiki pages on your blog will retain their content, as well as their revision history. These pages will still be available for reading, through the same URLs as before. The only change is that they will no longer be editable through the front end; all editing, and all browsing of the revision history, must happen through the Dashboard of your blog.

We're sorry for any inconvenience that this change might cause and we encourage you to get in touch if you and questions or concerns about this. In the upcoming months, we'll be researching ways to bring back this wiki-like functionality to WordPress blogs on the Commons. To keep up on news related to development on the CUNY Academic Commons, visit http://dev.commons.gc.cuny.edu.


okay -- let's forget the blog-theme switching thing. Maybe my memory on that is wrong.

#12 Updated by Boone Gorges about 11 years ago

The only problem with your changes is that they are not true. It doesn't really look like the plugin has been abandoned, or that it doesn't work on current WP versions. It's just that it's not very good.

#13 Updated by Matt Gold about 11 years ago

Okay. So, then, let's leave your original note as is. I made some minor stylistic changes that you can feel free to take or leave.

#14 Updated by Boone Gorges about 11 years ago

Where do you want the email to come from? Do we have a Commons address? Seems funny to send it from my gmail address. Or perhaps I could send it as a private message through the Commons?

#15 Updated by Matt Gold about 11 years ago

Yes, we have a Commons email account. Probably best to use that. Can you contact Sarah for the login credentials? Don't have time to look up password at the moment.

#16 Updated by Boone Gorges about 11 years ago

  • Status changed from Assigned to Resolved

The emails have been sent, and the plugin removed in https://github.com/castiron/cac/commit/4ea53a8a48cb05f121bd2fb191adb08bb5cf643d.

#17 Updated by Matt Gold about 11 years ago

Awesome. Thank you.

Also available in: Atom PDF