Project

General

Profile

Bug #6626

Files from non-member showing up in private group

Added by Marilyn Weber over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Group Files
Target version:
Start date:
2016-11-07
Due date:
% Done:

0%

Estimated time:

Description

User Sara Vogel reports:
"I use the files section for my private course grou (open only to people I approve as members) - https://commons.gc.cuny.edu/groups/fall-2016-foundations-of-bilingual-ed-at-hunter/. Someone named Nick Joseph Reyes's files are showing up here even though he is not a member of the group. I checked this folder Saturday, and only my files were there, so it had to have been between then and now that this glitch happened. Do you know how I can delete them from the folder? It doesn't give me the option. Also, how do I make sure the contents of my folders are protected from non-members?"

I went to this group and it is indeed still private, so I am utterly mystified here. I looked at the student's profile - https://commons.gc.cuny.edu/members/nickjoseph/groups/- and see that he is in an entirely different course - https://commons.gc.cuny.edu/groups/fall-2016-queens-eng130-ali/. It's my educated guess that his files were meant to be posted there.

How should I proceed? It seems logical to email the student to find out what he thinks he did, but I don't really know what that tells us.
The user would like to delete the files - can she be granted access to do that or can someone do it for her? Can we see if he also put these files in the Queens course group?

Has this happened before? It's a first for me!

https://commons.gc.cuny.edu/members/nickjoseph/groups/

SVogel.png (267 KB) SVogel.png Marilyn Weber, 2016-11-07 02:14 PM

Related issues

Related to CUNY Academic Commons - Bug #6632: Incorrect Files Showing up in Group FilesResolved2016-11-07

History

#1 Updated by Marilyn Weber over 3 years ago

Forgot to mention that she gave a screenshot - it's attached.

#2 Updated by Boone Gorges over 3 years ago

  • Target version set to 1.10.1

Hi Marilyn - This appears to be due to a new feature introduced in 1.10. See #5732.

There should be no privacy issue here with directly-uploaded files. I'll look into it.

#3 Updated by Boone Gorges over 3 years ago

This should now be resolved. To recap:

- Since 1.10, group Files pages have also showed forum attachments
- This particular group has its forum disabled
- There was a bug in the feature introduced in #5732 that caused incorrect items to be added to Files when the group had no forum

Fixed in https://github.com/cuny-academic-commons/cac/commit/276bd8a5f2713a7d1d914ae44149050a8aff47fd and deployed to the production site as a hotfix. Marilyn, could you let Sara know that the problem should be fixed, and ask her to verify before I close this out?

#4 Updated by Marilyn Weber over 3 years ago

She has just confirmed. Thanks for the speedy fix!

#5 Updated by Boone Gorges over 3 years ago

  • Related to Bug #6632: Incorrect Files Showing up in Group Files added

#6 Updated by Boone Gorges over 3 years ago

  • Status changed from New to Resolved

Thanks, Marilyn. On to #6632, which I guess is another version of the same bug.

Also available in: Atom PDF