Project

General

Profile

Bug #6893

Forum for CUNY Academic Commons Team is gone

Added by Marilyn Weber over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Group Forums
Target version:
-
Start date:
2016-11-30
Due date:
% Done:

0%

Estimated time:

Description

I've tried on IE, Chrome, and Firefox, and it appears that the forum for CUNY Academic Commons Team is gone. The error message is "This group does not currently have a forum."

History

#1 Updated by Matt Gold over 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

Hmmm. I see the forum both when logged in through my admin account and through the teststudent account. I imagine your bbpress permissions where somehow mangled?

#2 Updated by Marilyn Weber over 5 years ago

Yes, I can get in as teststudent as well.

#3 Updated by Marilyn Weber over 5 years ago

But it's gone for me as mweber.

#4 Updated by Marilyn Weber over 5 years ago

This is probably related - I also can't get to the dashboard at http://commons.gc.cuny.edu/

#5 Updated by Boone Gorges over 5 years ago

Marilyn, I have restored your permissions. Can you please try again?

I've reproduced the issue. bbPress is, predictably, doing something insane. I'm investigating.

#6 Updated by Marilyn Weber over 5 years ago

I'm back. Forum and Commons dashboard restored. Thanks Boone!

#7 Updated by Matt Gold over 5 years ago

  • Priority name changed from Normal to High

Hi Boone,

Apparently, this is happening for other users. We just received the following report:

I created a new group yesterday--The GC Running Group--and indicated in the group settings that I wanted to have a forum, but currently on the forum page I get three notices: "This forum is empty," "Oh bother! No topics were found here!" and "You cannot create new topics." I tried to uncheck and recheck the enable forum setting, but I have not seen a change in the forum notices and I still cannot create a new topic. I feel like I must be overlooking something, but after poking around a while, I can't figure it out!

------------------
Submitted from: http://commons.gc.cuny.edu/groups/running/forum/

#8 Updated by Boone Gorges over 5 years ago

  • Status changed from Assigned to Resolved
  • Priority name changed from High to Normal

I'm not 100% sure what's happening here. At some point, I may have disabled the bbPress-auto-role feature, because it appears (yet again) like it's the source of various lost-permission bugs around the Commons. It looks like this config change might be what's causing the forum problem described in this ticket. I thought I'd then try to work around the hardcoded "Participant" requirement of bbPress, but after a few hours of investigation, I don't know how to do it - bbPress is doing something that I don't understand. So, I've reenabled the auto-role feature, and group forums are now accessible in the same way as before.

Also available in: Atom PDF