Project

General

Profile

Bug #7100

Cincopa plugin problem

Added by Marilyn Weber almost 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2016-12-16
Due date:
% Done:

0%

Estimated time:

Description

A user reports:
"I noticed yesterday that none of my Cincopa galleries are loading on the Brooklyn College Archives' site. Instead of seeing the galleries, there are blinking dots where the galleries should appear. The same problem has occurred this morning.

Here's our url:
https://bcarchives1.commons.gc.cuny.edu/

Is Academic Commons no longer supporting Cincopa?"

They're not loading for me either. Any thoughts?

History

#1 Updated by Matt Gold almost 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Boone Gorges
  • Priority name changed from Normal to High

Boone or Ray -- can you please take a look at this tomorrow if possible? Thank you.

#2 Updated by Boone Gorges over 4 years ago

  • Status changed from Assigned to Reporter Feedback
  • Target version set to 1.10.5

Two plugins in use on https://bcarchives1.commons.gc.cuny.edu/ were incompatible with HTTPS: ShareThis and "Post video players slideshow and photo galleries". As such, JS execution on the page was being halted in two different places.

The ShareThis developers are aware of the issue, but apparently have no intention of fixing it. https://wordpress.org/support/topic/https-is-unsupported/

The other plugin was closed in the WP repository several years ago. It appears that its official replacement is "Post video players, slideshow albums, photo galleries and music / podcast playlist", which we also have installed on the Commons.

For both plugins, I've done the following:
- Modified the plugin itself (on the production site) to be HTTPS-compatible. https://github.com/cuny-academic-commons/cac/commit/90cf5d720541a653dfbd141e36425129fe652142 https://github.com/cuny-academic-commons/cac/commit/93c1b400123e6a59abdff61edf8fd9dbff6af3d0
- Added the plugins to our update blacklist https://github.com/cuny-academic-commons/cac/commit/3da04386db84afd4c5b1a27e21d327fdacb0c552. In the case of the Cincopa plugin, it doesn't matter, since it's no longer maintained. In the case of ShareThis, I'll set a reminder for a few months to check whether the issue has been fixed in the plugin.

The problem should be fixed, though you may have to clear your browser cache to see the changes reflected.

Marilyn, it would be helpful if you passed the information about the Cincopa plugin along to the site owner. If the user can verify that the new plugin is indeed a swap-out replacement for the old one, I can write a script that will switch the plugins for all sites on the Commons, so that we can remove the one that's defunct.

#4 Updated by Marilyn Weber over 4 years ago

If she hasn't already swapped out, what should she do? Deactivate the one she has, then choose it again from the plugins list?

#5 Updated by Marilyn Weber over 4 years ago

Cincopa isn't listed on the plugins list. Sorry to be confused by what you mean by "the new plugin is indeed a swap-out replacement for the old one"

#6 Updated by Boone Gorges over 4 years ago

  • Status changed from Reporter Feedback to Assigned

Marilyn - Sorry for the lack of clarity. The Cincopa plugins are horribly named.

I am in the process of verifying compatibility myself. Don't worry about asking the reporter to check it. You can just let the user know the problem is resolved.

I'll update this ticket when I've finished.

#7 Updated by Boone Gorges over 4 years ago

  • Status changed from Assigned to Resolved

I've migrated the sites over to the new plugin, and the old plugin will be removed as part of 1.10.5.

Marilyn, please feel free to reopen if the user continues to have issues.

Also available in: Atom PDF