Project

General

Profile

Bug #724

Word Limit on Email Notifications of Forum Posts?

Added by Matt Gold about 11 years ago. Updated about 11 years ago.

Status:
Rejected
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2011-04-29
Due date:
% Done:

0%

Estimated time:

Description

The email notification related to the update George Otte sent out today for the CUNY Academic Technology Committee meeting was cut off at a certain point. Is there a word limit on notifications? If so, perhaps we should lengthen it a bit. And if it is going to be cut off, there should be a message that says something like "Read the full post" with a link to the post.

History

#1 Updated by Boone Gorges about 11 years ago

Can you give me a sense of how much was cut off and how much was sent?

#2 Updated by Matt Gold about 11 years ago

Original post: 1214 words, 6265 characters (no spaces), 7469 characters (with spaces)

Notfication: 1077 words, 5873 chars (w/o spaces), 6963 chars (w/spaces)

#3 Updated by Boone Gorges about 11 years ago

Matt, I've tried to reproduce this on my local installation, but I can't. Messages of many thousands of words go through just fine. And I tried with George's very message, and it seemed to work fine as well. Can you tell me the point at which his original message was cut off (what word/sentence/phrase)?

#4 Updated by Boone Gorges about 11 years ago

(It's possible, fwiw, that George originally posted a truncated version of the message, which prompted the truncated email notification, but then immediately fixed it on the website. That'd explain why I can't reproduce it, and why this problem has not risen before.)

#5 Updated by Matt Gold about 11 years ago

Do you want me to ask George about this? Maybe he did post a truncated version. But I can forward you the message I received if needed. I realize that it isn't "proof" you're after, but reproducibility . . . .

#6 Updated by Boone Gorges about 11 years ago

Yes, please ask George.

And yes, please send me a copy. I'm not looking for proof, I'm just wondering whether there's a certain word pattern that might explain the truncation.

#7 Updated by Matt Gold about 11 years ago

I've asked George about this and forwarded the email.

#8 Updated by Matt Gold about 11 years ago

Here's George's response:

"I never noticed that. I didn't do anything unusual when I posted. The problem was with the post itself. I forgot to do close-quotation marks around the coding for the link. I went back in and edited that when I noticed the problem on the forum, but never registered the problem in the email post. "

#9 Updated by Boone Gorges about 11 years ago

  • Status changed from Assigned to Rejected

Thanks for forwarding the email. When George says he forgot some quotes on a link, I'm assuming he means the link to the TOS, which is the first word missing in the truncated message. That suggests that some invalid HTML had the effect of messing up the email filters. This is unsurprising. Links in posts to be emailed are handled by converting them to "text [url]", which is a custom filter that I wrote, and it would likely not know what to do with invalid HTML.

I can't really write the filter in such a way that it is able to account for all possible HTML syntax errors. And since we'll probably be reintroducing TinyMCE in forum textboxes in an upcoming release, it seems quite unlikely that this problem will arise with a frequency that should concern us.

#10 Updated by Matt Gold about 11 years ago

Agreed. It's good to know that improper formatting probably caused this. I'll keep my eye out for future occurrences.

Also available in: Atom PDF