Project

General

Profile

Bug #7286

Invalid certificate when using www prefix

Added by Raffi Khatchadourian over 2 years ago. Updated over 1 year ago.

Status:
Rejected
Priority name:
Normal
Assignee:
Category name:
Server
Target version:
Start date:
2016-12-30
Due date:
% Done:

0%

Estimated time:

Description

I get an invalid certificate error whilst visiting http://www.khatchad.commons.gc.cuny.edu.

History

#1 Updated by Matt Gold over 2 years ago

  • Category name set to Server
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

#2 Updated by Boone Gorges over 2 years ago

Hi Raffi - I've sent a message to IT for some clarification. In the meantime, don't use www. :-D

#3 Updated by Boone Gorges over 2 years ago

  • Target version set to Not tracked

#4 Updated by Boone Gorges over 2 years ago

Hi Raffi - I've had an exchange with our contact in IT. As I suspected, what you've described is not possible with our wildcard SSL configuration. Our SSL certificate is assigned to *.commons.gc.cuny.edu, a pattern not matched by www.khatchad.comons.gc.cuny.edu.

He and I are exploring a possible technique for working around this limitation, though it's kind of a long shot. I'll let you know what comes out of it.

#5 Updated by Boone Gorges over 1 year ago

  • Status changed from Assigned to Rejected

Sorry for losing this thread for a while.

I did talk to IT, and unfortunately, the specifics of our setup mean that we can't support the www. prefix on arbitrary subdomains on Commons sites.

If you see URLs anywhere in the interface that are prefixed with www, please let me know - this would qualify as a bug that needs fixing.

Thanks for your patience.

Also available in: Atom PDF