Project

General

Profile

Bug #7310

Friendship request mystery.

Added by Marilyn Weber 12 months ago. Updated 11 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
-
Target version:
Start date:
2017-01-04
Due date:
% Done:

0%


Description

Boone, Matt suggested I send this to you.

User Doris Grassbauer (https://commons.gc.cuny.edu/members/dgrasserbauer/) says she received a Friendship accepted notification from someone (Jean Eddy Saint Paul - http://cuny.is/drsaintpaul2016) she never sent a friendship invite to. She has sent other Friendship requests in the past. Do you have the power to see her requests? (In case she sent it a long time ago and forgot) Is there any possibility that Jean Eddy Saint Paul sent the request to her?

History

#1 Updated by Marilyn Weber 12 months ago

It has happened to Luke as well!

"This same thing happened to me 12/28 with Jean Eddy Saint Paul-- all of a sudden I got the notification that he had approved my friendship request, but I don't know him and never (intentionally) sent the request."

#2 Updated by Boone Gorges 11 months ago

Some very odd things happening here. Looping in Ray for any thoughts.

I can confirm that, around 6pm on Dec 28, 71 friend requests were generated that had this member as a recipient. Obviously, it's unlikely that 71 people would send this request at the same time, so something weird is afoot.

I looked at the access logs for this period, and nothing jumped out as odd. Certainly, there's no series of 71 requests that would generate these friendship items separately, so whatever happened must have piggybacked on one or more normal-looking requests.

In what might be a related issue, the user's friends page https://commons.gc.cuny.edu/members/drsaintpaul2016/friends/ was reporting over 1400 friends in the pagination, with most of the last 1390 pages or so consisting of a single user. On further investigation, it appears that about 40 users in our database had more than one entry for 'last_activity', which was throwing off user counts (in the case of one user, there were over 1600 entries). I'm not sure how this happened. I ran a script to clean it up (deleted all 'last_activity' entries for these users, with the exception of the most recent one) and now pagination is looking correct.

Ray, any ideas?

#3 Updated by Marilyn Weber 11 months ago

Just curious - it appears that 71 friend requests were sent FROM Jean Eddy Saint Paul? Or TO Doris Grassbauer?

Apparently I too received and accepted one from Jean Eddy Saint Paul.

#4 Updated by Boone Gorges 11 months ago

Just curious - it appears that 71 friend requests were sent FROM Jean Eddy Saint Paul? Or TO Doris Grassbauer?

Neither: 71 friend requests were sent TO Jean Eddy Saint Paul FROM 71 different Commons users, yourself included.

#5 Updated by Marilyn Weber 11 months ago

Ah, I see. Like Doris and Luke, I did not send anything to him.

#6 Updated by Luke Waltzer 11 months ago

Perhaps related, or perhaps not: today, Janette Tilley (jtilley) accepted a friend request that I did not send. She is though in a new private group I'm a member of.

#7 Updated by Raymond Hoh 11 months ago

Hmm, interesting.

Boone, do you think it might have something to do with Invite Anyone's auto-friend functionality when an invited user is activated (see invite_anyone_activate_user())?

#8 Updated by Boone Gorges 11 months ago

  • Target version set to 1.10.7

Good call, Ray. That's it. The problem is due to a recent change I made in Invite Anyone. I have a hotfix in place for the moment, and I'll update this ticket with more details and a proper fix later today.

#9 Updated by Boone Gorges 11 months ago

  • Status changed from New to Resolved

Here is a description of the bug and its proper fix: https://github.com/boonebgorges/invite-anyone/issues/141

I'll leave my hotfix in place until 1.10.7, when we'll get the proper fix from upstream.

Also available in: Atom PDF