Project

General

Profile

Bug #7623

bbPress Forum and "Add users" widget User Role

Added by Laurie Hurson almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2017-02-03
Due date:
% Done:

0%

Estimated time:

Description

As reported by a CAC Faculty Fellow:

"he issue I’m having is a conflict regarding user roles between the “Add Users Sidebar Widget” and bbPress. Under Forum Settings for bbPress, if Auto-Role is defined to automatically give registered visitors the participant role in forums, anyone who visits the site is automatically given the role “participant” under both Site Role and Forum Role. So even if I have Add Users configured, it never asks for the password to join the site because everyone is automatically joined as “participant”. This means that they cannot post as author. But if I uncheck “Auto-Role” for bbPress, forums can’t even be seen, let alone participated in.

When I deactivate bbPress, Add Users works as it should, so I think this is a bbPress bug."

Thread here: https://commons.gc.cuny.edu/groups/cac-faculty-fellows/forum/topic/forums-add-users/

History

#1 Updated by Boone Gorges almost 5 years ago

  • Category name changed from BuddyPress (misc) to WordPress Plugins
  • Status changed from New to Resolved
  • Target version set to 1.10.10

Thanks very much for the report!

I've reproduced the issue. I don't disagree that there is something odd about the way that bbPress behaves in this context. But the way that bbPress's behavior is codified makes it very difficult to address in bbPress itself. Looking closer at the Add Users code - which has been abandoned by the author - I see some fairly loose logic that doesn't anticipate situations like bbPress, where a user might have more than one role on a WordPress site. Instead of fixing the problem in bbPress, I've opted to rewrite the relevant part of the Add Users widget so that this problem shouldn't recur.

The relevant changeset is https://github.com/cuny-academic-commons/cac/commit/f64d0ad33c90608c6b4ad8776faff0b4045d1adb (you won't be able to view this). The fix will be live in our next release, scheduled for the 11th.

Also available in: Atom PDF