Project

General

Profile

Feature #7653

Reckoning Plugin Edit or Workaround

Added by Laurie Hurson almost 5 years ago. Updated about 2 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Reckoning
Target version:
Start date:
2017-02-08
Due date:
% Done:

0%

Estimated time:

Description

Reckoning Plugin does not pull private posts.

Is there an easy fix/ plugin edit to pull in private posts? If not, any other workaround suggestions for tracking students' private posts?

History

#1 Updated by Luke Waltzer almost 5 years ago

  • Category name set to WordPress Plugins
  • Assignee changed from Luke Waltzer to Boone Gorges

I have confirmed that Posts marked "private" do not aggregate via Reckoning. Posts that are pw-protected are indexed in the User Summary, but post content does not display (admin can click through).

@Boone, do you mind taking a quick look at Reckoning to see if getting it to pull and display private or pw-protected posts is a quick fix? If not, we'll work on finding a work around.

#2 Updated by Boone Gorges almost 5 years ago

  • Status changed from New to Reporter Feedback

It looks like it's a one- or two-line change to pull in private posts. (The plugin currently uses the default value for the 'post_status' argument, which is 'public'. I'd need to override that.) I can:

a. Send the suggested fix to Shawn
b. Make the suggested fix in our version of the plugin, so that we maintain a fork
c. Come up with a way to override the 'post_status' param in a secondary plugin - not terribly difficult, but somewhat fragile if the plugin is updated in certain ways in the future

#3 Updated by Luke Waltzer almost 5 years ago

Thanks for taking a look at this, Boone!

I'll defer to you to select the best/easiest path here... fwiw, not sure that Shawn is actively maintaining the plugin or doing much WP work these days, but it would be great to let him know of any changes to the plugin. For the purposes of the course that generated this request, if we can get a fix onto the Commons by mid-March (midterm time), that would be great.

#4 Updated by Boone Gorges almost 5 years ago

  • Status changed from Reporter Feedback to Resolved
  • Target version set to 1.10.10

I created a pull request for Shawn's repo: https://github.com/shawnrice/reckoning/pull/2

I also put a fix in on the Commons that doesn't involve modifying the plugin. It's non-ideal, but I don't want to have to worry about a future situation where our forked version of the plugin is rolled back or updated incorrectly. https://github.com/cuny-academic-commons/cac/commit/78d799c90beaaf6b724e33826c070570f16996ea

This will be part of the next scheduled release, on the 11th.

#5 Updated by Luke Waltzer almost 5 years ago

You rule, Boone. Thanks.

@Laurie-- could you please let Janette know this is coming?

#6 Updated by Boone Gorges about 2 years ago

  • Category name changed from WordPress Plugins to Reckoning

Also available in: Atom PDF