Project

General

Profile

Bug #7762

RBE post didn't go through

Added by Luke Waltzer over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Reply By Email
Target version:
Start date:
2017-03-20
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)

Description

Replied by email to forum thread, using iPad. This thread -- https://commons.gc.cuny.edu/groups/cac-faculty-fellows/forum/topic/add-users-sidebar-widget-disappeared/#post-53857. Didn't go through.

Screenshot of sent email attached.

IMG_0630.PNG (274 KB) IMG_0630.PNG Luke Waltzer, 2017-03-07 07:06 AM
Screen Shot 2017-03-07 at 10.03.18 AM.png (199 KB) Screen Shot 2017-03-07 at 10.03.18 AM.png Luke Waltzer, 2017-03-07 10:05 AM

Subtasks

Bug #7815: RBE "Connect" button hangsResolvedRaymond Hoh


Related issues

Related to CUNY Academic Commons - Bug #7825: WP Cron fails to spawn on productionRejected2017-03-22

Related to CUNY Academic Commons - Bug #5884: Reply by email double posting issuesResolved2016-08-10

History

#1 Updated by Luke Waltzer over 4 years ago

(the reply that's there I posted directly)

#2 Updated by Luke Waltzer over 4 years ago

Elevating priority... confirmed RBE is not working on another thread -- https://commons.gc.cuny.edu/groups/coursetest/forum/topic/testing-rbe/#post-53858.

Screenshot of email attached.

#3 Updated by Luke Waltzer over 4 years ago

Just got four emails from this post -- https://commons.gc.cuny.edu/groups/digital-humanities-initiative/forum/topic/fwd-invitation-to-digital-paxton-launch-events-2/.

And then just got four rejection messages each for my earlier replies.

Hi there,

Unfortunately, your reply to the forum topic could not be posted because it appears you have already made the same reply.

Here is a copy of your reply:

"RBE."

We apologize for any inconvenience this may have caused.

#4 Updated by Raymond Hoh over 4 years ago

  • Status changed from New to In Progress

It looks like RBE stopped working at 11:10am ET.

Not sure why. Looking into it.

#5 Updated by Raymond Hoh over 4 years ago

So the problem is the remote POST response used to trigger RBE is no longer responding:
https://github.com/cuny-academic-commons/cac/blob/1.10.x/wp-content/plugins/bp-reply-by-email/includes/bp-rbe-functions.php#L1350

I'm guessing IT has put in some security restrictions on POST responses. For the moment, I have manually triggered RBE. I'll look into adding some code that doesn't use a POST response to trigger RBE on the RBE settings page.

#6 Updated by Luke Waltzer over 4 years ago

Boone, think this is worth a follow up with Lihua?

#7 Updated by Raymond Hoh over 4 years ago

Let me do some more debugging before we contact Lihua.

#8 Updated by Raymond Hoh over 4 years ago

I've written some new logic so RBE can spawn new inbox checks from the RBE admin settings page.

This approach doesn't use a loopback POST response as before, but instead uses AJAX to do the initial ping.

The good thing is this approach will probably stop our problem with RBE duplicate posts from occurring since you can only spawn new inbox checks from the admin settings page and not on a pageload basis like before.

The problem is if the Commons goes down or if RBE isn't able to connect to the inbox during a scheduled ping, someone will need to manually go to the RBE admin settings page and hit the "Connect" button.

To remedy this, I can write a task hooked to WP cron (perhaps run hourly) to check if RBE is connected. If RBE isn't connected, it can email some of us to go to the RBE settings page and re-connect.

FYI: This code is live on the Commons, but I haven't committed it to the CAC repo yet as I'm still monitoring things, but initial logs look good on my end.


It might be good to ping Lihua just to see what has changed exactly or to see if something like fail2ban is blocking the loopback POST response.

#9 Updated by Raymond Hoh over 4 years ago

  • Status changed from In Progress to Resolved
  • Target version set to 1.10.13

Boone - I've added the updated RBE code to 1.10.x branch:
https://github.com/cuny-academic-commons/cac/commit/14cc98d54675e907dc00726efd2757a8b48e52bb

And on production, I have cherry-picked the commit. RBE is already up-and-running; you shouldn't have to do anything for the maintenance release today.

One thing I haven't done is write a task hooked to WP cron to email one of us should the IMAP connection go down, but I can do this before the next maintenance release on the 21st.

Going to mark this as resolved.

#10 Updated by Raymond Hoh over 4 years ago

  • Related to Bug #7825: WP Cron fails to spawn on production added

#11 Updated by Raymond Hoh over 2 years ago

  • Related to Bug #5884: Reply by email double posting issues added

#12 Updated by Raymond Hoh over 2 years ago

  • Related to Bug #8991: RBE duplicate email message issue added

#13 Updated by Raymond Hoh over 2 years ago

  • Related to deleted (Bug #8991: RBE duplicate email message issue)

Also available in: Atom PDF