Project

General

Profile

Bug #7815

Bug #7762: RBE post didn't go through

RBE "Connect" button hangs

Added by Raymond Hoh over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Reply By Email
Target version:
Start date:
2017-03-20
Due date:
% Done:

0%

Estimated time:

Description

In #7762, I implemented a "Connect" button on the RBE admin settings page to workaround some issues with initializing the IMAP connection to GMail and to also stop the outstanding problem with duplicate posts caused by duplicate IMAP connections.

Last week, I encountered an issue with the "Connect" button as it was making the browser hang on any Commons page even after closing the browser tab only (this only occurred for the user that clicked on the button). The hang would only go away after clearing the browser's cookies.

I discovered that the problem was due to WP Ajaxify Comments and how it opens a PHP session without closing it.

More info on how PHP sessions can impact WordPress can be found on this blog post:
https://pressjitsu.com/blog/wordpress-sessions-performance/

I fixed this here:
https://github.com/cuny-academic-commons/cac/commit/8481d75d804c5551ca6afa508a8981b793e6223e


Also in #7762, I said that I wanted to create an hourly task for WP cron that would check if the IMAP connection is down:
https://redmine.gc.cuny.edu/issues/7762#note-9

If the connection is down, it should send an email to notify us to go the RBE admin settings page to reinitiate the connection.

I've also done this and I've set the email recipient to myself for now:
https://github.com/cuny-academic-commons/cac/commit/e99a6321b34a5e5348b40e342fd8f8ae9db4134d

If you want to be added to this list, let me know.

History

#1 Updated by Raymond Hoh over 2 years ago

  • Status changed from New to Resolved

Forgot to mark this as resolved.

Also available in: Atom PDF