Project

General

Profile

Actions

Support #7810

closed

Brunelleschi theme deprecation

Added by scott voth over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
WordPress Themes
Target version:
Start date:
2017-03-17
Due date:
% Done:

0%

Estimated time:

Description

Can we see if anyone is using the Brunelleschi theme? If not, maybe we should just rid of it. None of its header settings seem to work.

Actions #1

Updated by Boone Gorges over 5 years ago

  • Status changed from New to Reporter Feedback
  • Target version set to Not tracked

Brunelleschi is used by 52 sites, and is currently available to new sites.

I just activated the theme for testing, and I can confirm that the Header Image feature doesn't seem to work. That's the only header-related setting I saw - Scott, am I missing something else?

I'd argue against removing the theme altogether, but I'd be fine with disabling it for new sites if there are major problems with it.

Actions #2

Updated by scott voth over 5 years ago

Yes, that's the one. One member said she spent a lot of time looking for a suitable theme, then chose this one, and was annoyed that it didn't work.

Actions #3

Updated by Matt Gold over 5 years ago

let's definitely disable for future users

Actions #4

Updated by Boone Gorges over 5 years ago

  • Status changed from Reporter Feedback to Resolved
  • Target version changed from Not tracked to 1.10.15

There appears to be a coding error that's causing the problem - I think that when the theme author migrated some custom settings to WP's built-in 'custom-header' functionality, they forgot to make the modification in one place. I've fixed it in https://github.com/cuny-academic-commons/cac/commit/5a811ed8df9a9fdcba985b2a2ef0fed5bd827d5b

Still, the theme has not been updated since late 2012, and is no longer publicly listed in the wordpress.org theme repository. I'm going to disable it so that it can't be activated in the future. Sites currently running the theme will be unaffected (save for the bugfix described above).

Actions

Also available in: Atom PDF