Project

General

Profile

Bug #8167

Replying to existing topic via RBE can start new topic

Added by Boone Gorges over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
Reply By Email
Target version:
Start date:
2017-05-18
Due date:
% Done:

0%

Estimated time:

Description

Here's the scenario:

- I got an email notification of https://commons.gc.cuny.edu/?p=56071. Subject: (CUNY Academic Commons Team) Re: Topic - Timeline for Release 1.11
- I replied to it via RBE
- Reply was posted as a new topic https://commons.gc.cuny.edu/groups/cac-community-team-project-planning/forum/topic/re-cuny-academic-commons-team-re-topic-timeline-for-release-1-11/ Topic title is Re: (CUNY Academic Commons Team) Re: Topic – Timeline for Release 1.11

Maybe something funky is happening with RBE topic lookups, in combination with our custom subject line?

Let me know if you need full emails.

History

#1 Updated by Raymond Hoh over 2 years ago

  • Status changed from Assigned to In Progress

Looking into it.

#2 Updated by Raymond Hoh over 2 years ago

  • Status changed from In Progress to Resolved

Ugh, the problem is the bp-rbe-new-topic plugin was overriding the Reply-To email address on all group pages, when it should only override the RBE email address during the "Post New Topic via Email" block on a group's "Forum" page. Because bbPress forum replies post to /forum/topic/XXX (in bp-default themes!), if someone was posting a regular reply on the web, this is where this problem came up.

Fixed in https://github.com/cuny-academic-commons/cac/commit/851a380d7a91a13050f6fe0ade2f1b030d79ecf8 and deployed as a hotfix on production.

#3 Updated by Boone Gorges over 2 years ago

Thanks for your quick work!

Also available in: Atom PDF