Project

General

Profile

Actions

Bug #8917

closed

Files not downloading from Groups properly

Added by Marilyn Weber almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
Group Files
Target version:
Start date:
2017-11-16
Due date:
% Done:

0%

Estimated time:

Description

User Sara Vogel [mailto:] reports:

"Across two different groups that I am involved with (https://commons.gc.cuny.edu/groups/qualitative-research-in-education-2017/ and https://commons.gc.cuny.edu/groups/fall-2017-foundations-of-bilingual-ed-at-hunter/) I am not able to download files from the FIles section of the groups.

Acrobat Reader gives me an error message when I try to download PDFs
and when I try to download word documents, it downloads the file, but the word doc is blank."

I've attached the screenshot of the error message.


Files

error.png (26.1 KB) error.png Marilyn Weber, 2017-11-16 10:38 AM

Related issues

Related to CUNY Academic Commons - Bug #8880: get_group_doc should use X-SendfileResolvedBoone Gorges2017-11-01

Actions
Actions #1

Updated by Matt Gold almost 5 years ago

  • Category name set to Group Files
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges
  • Priority name changed from Normal to High

Hi Marilyn,

Can you please give this a quick test on one of our groups?

Actions #2

Updated by Boone Gorges almost 5 years ago

Downloads are working generally, but I can confirm after a spot-check that a number of files in the bilingual-ed group are downloading as empty. I'm looking into it.

Actions #3

Updated by Boone Gorges almost 5 years ago

  • Target version set to 1.12.2

It looks like the changes in #8880 introduced problems with certain sorts of downloads. I have temporarily rolled back the changes in that ticket, and files are now downloading properly. I've reached out to IT to make the configuration change necessary to enable X-SendFile support in the bp-group-documents directory.

Actions #4

Updated by Boone Gorges almost 5 years ago

  • Related to Bug #8880: get_group_doc should use X-Sendfile added
Actions #5

Updated by Boone Gorges almost 5 years ago

  • Target version changed from 1.12.2 to 1.12.3

I haven't heard back from IT yet, so I'm pushing this one to the next release.

Actions #6

Updated by Boone Gorges almost 5 years ago

  • Status changed from Assigned to Resolved

Lihua made the requested change on the server, but it's still not working correctly. The time sunk into tweaking group File downloads in this way is probably not worth the meager benefit, so I'm going to leave the feature disabled for the purposes of bp-group-documents. No further action here is needed.

Actions #7

Updated by Matt Gold almost 5 years ago

Hi Boone -- I'm unclear. What do we tell the members of this group?

Actions #8

Updated by Boone Gorges almost 5 years ago

Documents are downloading correctly. The original bug was that I'd tried to implement a performance improvement, but it's proved to be too difficult to implement, so I've rolled it out. We are back at the status quo.

Actions

Also available in: Atom PDF