Project

General

Profile

Feature #9070

Shortcodes for seven iframe embeds for JITP

Added by Kimon Keramidas almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2018-01-09
Due date:
% Done:

0%

Estimated time:

Description

Sundial Video 1: <iframe src="https://archive.org/embed/fig02" width="960" height="720" frameborder="0" webkitallowfullscreen="true" mozallowfullscreen="true" allowfullscreen></iframe>

Sundial Video 2: <iframe src="https://archive.org/embed/fig05" width="960" height="720" frameborder="0" webkitallowfullscreen="true" mozallowfullscreen="true" allowfullscreen></iframe>

Sundial Video 3: <iframe src="https://archive.org/embed/fig06" width="960" height="720" frameborder="0" webkitallowfullscreen="true" mozallowfullscreen="true" allowfullscreen></iframe>

Sundial Video 4: <iframe src="https://archive.org/embed/fig09_201801" width="960" height="720" frameborder="0" webkitallowfullscreen="true" mozallowfullscreen="true" allowfullscreen></iframe>

Sundial Video 5: <iframe src="https://archive.org/embed/fig11_201801" width="960" height="720" frameborder="0" webkitallowfullscreen="true" mozallowfullscreen="true" allowfullscreen></iframe>

Sundial Video 6: <iframe src="https://archive.org/embed/fig16" width="960" height="720" frameborder="0" webkitallowfullscreen="true" mozallowfullscreen="true" allowfullscreen></iframe>

Volunteer park: <iframe width="960" height="540" src="https://www.youtube.com/embed/IIzcnKByX4s?rel=0" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>

History

#1 Updated by Matt Gold almost 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Raymond Hoh

Hi Ray,

Are you able to create these, or does this need to wait for Boone?

#2 Updated by Raymond Hoh almost 4 years ago

Kimon, can you try using the Jetpack plugin with Shortcode Embeds?

Documentation can be found here:
https://jetpack.com/support/shortcode-embeds/
https://en.support.wordpress.com/videos/the-internet-archive/

#3 Updated by Kimon Keramidas almost 4 years ago

No, we need custom embed codes, particularly since for archival and search ability purposes we use the Internet Archive to stream JITP's video. No embed code for Internet Archive in Jetpack

#4 Updated by Kimon Keramidas almost 4 years ago

This is how we've always done it in the Commons.

#5 Updated by Kimon Keramidas almost 4 years ago

Sorry if that all seemed curt and demanding. Writing in a rush and posting quickly has made this all come off poorly. Greatly appreciate all that you guys provide for us. Hope you guys can help us while Boone is away, but if not that is understood as well. Let me know if I can provide any more information to make things easier.

#6 Updated by Raymond Hoh almost 4 years ago

Hi Kimon,

No problem. I understand that you and Boone might have a shorthand from working on similar tickets, so I apologize for not knowing your protocol with embedding beforehand.

However, regarding:

No embed code for Internet Archive in Jetpack

I do suggest giving Jetpack a try regardless. To test, activate the Jetpack plugin and add the following in your post:

[archiveorg id=fig02 width=960 height=720]

If it isn't working, make sure the Shortcode Embeds module is activated in Jetpack:
https://jetpack.com/support/control-jetpacks-modules-on-one-page/

If you still require something custom, let me know and I will work on it.

#7 Updated by Kimon Keramidas almost 4 years ago

I just tried this and something is keeping me from enabling the Shortcode Embed module in Jetpack. It would be a great solution because we will be using Archive.org moving forward so if we can get it to work that would be great. I think there might be something in the Commons blocking the activation of the module.

Thanks for your help and finding this solution. Hope it works

BTW, here is the URL that I get when the Module activation fails: https://jitpstaging.commons.gc.cuny.edu/wp-admin/admin.php?page=jetpack&action=bulk-activate&modules%5B%5D=shortcodes&_wpnonce=679cd202e3

I tried to both individually and bulk activate it and it failed the same way both times.

K

#8 Updated by Raymond Hoh almost 4 years ago

  • Category name set to WordPress Plugins
  • Status changed from Assigned to Resolved
  • Target version set to 1.12.7

I took a look at the JITP staging site and found that the problem is due to a conflict between the "Simpler iPaper" plugin and Jetpack.

Both plugins use the same-named function, scribd_shortcode_handler(), which causes a fatal error when you attempt to use both plugins.

So to activate Jetpack's Shortcode Embeds module, deactivate the Simpler iPaper plugin first.

Once I deactivated the Simpler iPaper plugin, I was able to activate Jetpack's Shortcode Embeds module and the [archiveorg] shortcode will now work in posts.

To aid in using Jetpack, I also installed the "Jetpack Dev Mode" plugin (this is deployed on production).

(Internal reference - https://github.com/cuny-academic-commons/cac/commit/1c3b9936b47d31a469b1ff173016b3fcf8ea29fa)

Once you activate this plugin in conjunction with Jetpack, you won't need to login with a WordPress.com account to use basic modules such as the Shortcode Embeds one.

For the full list of modules you can use without a WordPress.com account, view the modules page:
https://jetpack.com/support/control-jetpacks-modules-on-one-page/

Let me know if you have any other questions.

#9 Updated by Kimon Keramidas almost 4 years ago

Got Jetpack working, all embeds are good to go. Thanks for the help. This ticket can be closed!

Also available in: Atom PDF