Project

General

Profile

Bug #9076

Email group subscription reset erroneously

Added by Matt Gold about 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Start date:
2018-01-11
Due date:
% Done:

0%

Estimated time:

Description

Hi Ray,

Yesterday I was helping someone with the NYCDH announcements group. When I visited it, I noticed that my email subscription had been set to No Email, whereas it should have been set to all email. do you have any idea what might be going on and whether this might be indicative of a wider problem?


Related issues

Related to CUNY Academic Commons - Bug #10144: Subscription set to "no email"Resolved2018-08-13

History

#1 Updated by Raymond Hoh about 4 years ago

Hi Matt,

Just to confirm, was the "No Email" subscription for the user having the problem or was it your own account?

If it was for the other user, do you know if that user was invited via Invite Anyone or did an admin manually add the user to the site? Or did that user use the regular registration form to sign-up?

#2 Updated by Matt Gold about 4 years ago

The erroneous "No Email" subscription was set for me, not the other user.

#3 Updated by Raymond Hoh about 4 years ago

Was it always set to "No Email"?

Did you receive any emails from the NYCDH Announcements group prior to this? Or did the subscription setting change recently?

#4 Updated by Matt Gold about 4 years ago

Was it always set to "No Email"?

I don't think so. I assume it was set to "All Email," which is how I usually have things set.

Did you receive any emails from the NYCDH Announcements group prior to this? Or did the subscription setting change recently?

Yes, I had been receiving emails regularly. It was when I visited the group page that I noticed that "No Email" was my setting. I did not purposefully change anything recently, not had I been near this part of the site. So I don't know how this could have happened

#5 Updated by Matt Gold about 4 years ago

Hi Ray -- I looked through other members of this group today and saw a few I did not expect to have set to "No email." One, Claire Potter, wrote: "I did not set it up that way -- and I wondered why I had stopped getting notifications!"

So, I think we have a small problem on our hands -- we should try to figure out how this might have happened and how we might remedy it.

#6 Updated by Raymond Hoh about 4 years ago

  • Assignee changed from Matt Gold to Raymond Hoh

It's kind of hard to debug the problem without any steps to duplicate.

What I can do in the meantime is to write and run a script that finds any users subscribed to "No Email" in the Announcements group and to change these subscriptions back to "All Mail".

Did we ever run into a similar bug on the Commons? We might have. Will look through Redmine to see what I can find.

#7 Updated by Matt Gold about 4 years ago

Hi Ray -- that would be a good solution for the Announcements group. But FYI, the group in question is the Steering Group -- http://nycdh.org/groups/nycdh-steering-group/

#8 Updated by Matt Gold about 4 years ago

(and the bug does sound somewhat familiar to something we might have experienced previously on the Commons. I feel like bbpress might have been to blame somehow, but that generally seems like a safe bet to make!

#9 Updated by Matt Gold almost 4 years ago

just heard about another instance of this -- will forward details via email

#10 Updated by Raymond Hoh almost 4 years ago

Hi Matt,

There were 8 members in the Steering Group that had "No Email" as their subscription.

I've just updated their subscriptions to "All Mail". I'll let you know the list of these users via email.

For the main Announcements group, 86 people have their subscription set to "No Email". I'm not sure if I want to override their settings to "All Mail" since some might have manually set their subscription to "No Email" intentionally.

Let me know what we want to do here.

#11 Updated by Raymond Hoh almost 4 years ago

Related: https://redmine.gc.cuny.edu/issues/2082

Although related, it doesn't seem that the Commons ticket has much relevance to this one since it was a custom plugin that was causing the problem on the Commons, but I linked to it anyway.

#12 Updated by Matt Gold almost 4 years ago

Thank you, Ray. I am checking in with Elizabeth and will let you know what she says.

I agree that if people are set to No Announcements on email, we should probably leave it as is. I do wish we were able to record the date a user last changed that preference. It would be valuable metadata. Imagine, for instance, if we say that all settings were changed at the same moment --we'd know that something fishy was going on.

#13 Updated by Matt Gold almost 4 years ago

Hi Ray -- somehow, my subscription to the announcements group on NYCDH was reset to No Email. Can you please look into this? FYI, we have a script, I think, that automatically subscribes people to this group when they join. Everyone on the site is supposed to be subscribed to this group. It is problematic if people aren't getting the email notifications.

I have not touched my subscription, and I did not change it back to "All Email" to fix the problem

#14 Updated by Raymond Hoh almost 4 years ago

Hi Matt,

My time was spent working on the onboarding project last week and I forgot about this.

I'll spend some time to add some debugging logs to see whereabouts this bug might be taking place.

#15 Updated by Matt Gold almost 4 years ago

Okay - thanks and no worries.

#16 Updated by Raymond Hoh almost 4 years ago

  • Status changed from Assigned to In Progress

I've added some debug logging at the time when group email subscription changes are made.

Hopefully, that will give us some clues as to what is causing group subscriptions to change.

Let me know if you encounter any erroneous changes again so I can check the logs.

#17 Updated by Matt Gold almost 4 years ago

Okay will do. Thanks, Ray. Did you reset my subscription?

#18 Updated by Raymond Hoh almost 4 years ago

I did not reset your subscription, Matt.

#19 Updated by Raymond Hoh over 3 years ago

  • Related to Bug #10144: Subscription set to "no email" added

#20 Updated by Raymond Hoh over 3 years ago

  • Status changed from In Progress to Resolved

Similar to #10144, I've deployed the same fix I made for CAC to NYCDH.

Let me know if we are still getting reports of email unsubscriptions after this fix, but for now, I'll mark this as resolved.

#21 Updated by Matt Gold over 3 years ago

Great. thank you, Ray!

Also available in: Atom PDF