Project

General

Profile

Bug #908

Free a BP Doc from Locked Status

Added by Matt Gold almost 11 years ago. Updated almost 11 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2011-07-02
Due date:
% Done:

0%

Estimated time:

Description

Members of a hidden group I'm in are unable to edit one of our group documents because it shows that a member is currently editing the document. Here's the error message we see:

"This doc is currently being edited by [Member Name]. To prevent overwrites, you cannot edit until that user has finished. Please try again in a few minutes."

It has shown this error message for at least a week. While it is theoretically possible that the member in question still has the doc open on a browser tab somewhere, I doubt it.

There are a few things to think about here besides freeing up this particular doc -- perhaps there should be some reasonable limit (two hours?) after which a user with an open doc gets a message saying that the doc will be closed (with changes saved) unless he or she indicates that more time is needed to work on the doc.

History

#1 Updated by Boone Gorges almost 11 years ago

  • Status changed from Assigned to Reporter Feedback

perhaps there should be some reasonable limit (two hours?) after which a user with an open doc gets a message saying that the doc will be closed (with changes saved) unless he or she indicates that more time is needed to work on the doc.

This already exists. I believe the idle time is 20 or 30 minutes, I forget which.

The problem is that this solution is JavaScript-based, which means that it's browser-based. What probably happened is that the user in question opened the Doc in Edit mode, and then closed the browser, so that the edit lock cancel JS was never called. I'm aware of this issue https://github.com/boonebgorges/buddypress-docs/issues/44. I'll have a look at it when I get a chance.

As for this particular Doc, group admins (and super admins) can "force cancel" the edit lock, by clicking on the Lock icon at http://commons.gc.cuny.edu/groups/journal-of-interactive-technology-and-pedagogy/docs/list-of-reviewers-and-board-members, and then clicking "force cancel" on the slider. I'll leave it for you to do, so that you see how it's done, though please let me know if you'd like me to do it on your behalf.

#2 Updated by Matt Gold almost 11 years ago

  • Status changed from Reporter Feedback to Resolved

Thanks, Boone. And in fact, I saw the idle limit function in action on another doc (you probably received an email update, since we're both part of the group).

Thanks for the tip -- just force-cancelled the lock.

Also available in: Atom PDF