Project

General

Profile

Bug #9374

Admins are not getting email notifications of posts

Added by Syelle Graves 12 months ago. Updated 2 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Group Blogs
Target version:
Start date:
2018-03-09
Due date:
% Done:

0%

Estimated time:

Description

Hi Boone,
Fancy meeting you here!

Cecelia Cutler and I are admins of this site:
https://discourse2018.commons.gc.cuny.edu/wp-admin/options-writing.php

Even though I have my settings set to "all email," we've never gotten any emails when users post, nor when users comment on posts.

My dashboard settings > discussion is set to "email me whenever anyone posts a comment."

I do get emails when users request to join the group, and I got an email when a comment was held in moderation.

One possible related issue is that even though I'm "following" my own site, my site is not listed in "sites I follow":

My followed sites don't include this discourse 2018 site:
https://commons.gc.cuny.edu/members/syellegraves/blogs/following/

Here are two examples of posts I never got notified of (nor any of their comments):
https://discourse2018.commons.gc.cuny.edu/2018/02/26/micro-expressions/
https://discourse2018.commons.gc.cuny.edu/2018/03/02/questions-for-matt-garley/

I found several closed tickets that seemed similar, like this one, but I have no idea if they're related:
https://redmine.gc.cuny.edu/issues/6818

I don't know if authors are getting emails of new posts.

Any ideas? Lmk if you need more info, or if any of my details don't make sense!

Thanks!
Syelle

History

#1 Updated by Syelle Graves 12 months ago

(And nothing's in my spam!)

#2 Updated by Boone Gorges 11 months ago

  • Category name set to Group Blogs
  • Status changed from New to Reporter Feedback

Hi Syelle - Nice to see you :-D

It appears that the issue is the privacy level of your site. At the moment, sites must be fully public ("Allow search engines to index this site") in order for site content - blogs, comments - to appear in the activity stream of the corresponding group https://commons.gc.cuny.edu/groups/analyzing-discourse-data-spring-2018-cutler/. And it's these activity items that trigger email notifications within the group.

For the time being, if you'd like email notifications, you'll need to switch the setting at Dashboard > Settings > Reading. Otherwise, we'll be looking to change this behavior in the next major feature release for the Commons. You can follow #8075 for more information.

#3 Updated by Boone Gorges 11 months ago

  • Target version set to Not tracked

#4 Updated by Syelle Graves 11 months ago

Thanks very much for this, Boone. Bree actually called it when I mentioned it to her the other day!

I'm also very glad that the behavior will likely be changed in the future; I'll follow the ticket like you suggest.

~Syelle

#5 Updated by Boone Gorges 2 months ago

  • Status changed from Reporter Feedback to Resolved

Also available in: Atom PDF