Project

General

Profile

Bug #11801

Selecting 'CUNY-wide' when creating group/site forbids selection of other campuses

Added by Matt Gold over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Groups (misc)
Target version:
Start date:
2019-08-27
Due date:
% Done:

0%

Estimated time:

Description

In the group metadata, I selected "CUNY-wide" but then also tried to select a second campus (the GC). The system did not seem to allow me to add a second campus once CUNY-wide was selected. I'm not sure whether that was a conscious choice or not, and I suppose the answer about whether it should be depends on how "CUNY-wide" works -- would it, in filtering, bring back groups associated with any campus in CUNY (ie, would a CUNY-wide group come up in a filter set for Queensborough CC) or is CUNY-wide its own category?

History

#1 Updated by Boone Gorges over 2 years ago

  • Subject changed from Campus selection UX issue to Selecting 'CUNY-wide' when creating group/site forbids selection of other campuses
  • Assignee changed from Boone Gorges to Sonja Leix
  • Target version set to 1.16

This was by design. CUNY-wide supersedes individual campuses. How this behaves during filtering is something that will have to be determined.

Assigning to 1.16 so that it's properly considered in conjunction with filters.

#2 Updated by Sonja Leix about 2 years ago

Boone Gorges wrote:

This was by design. CUNY-wide supersedes individual campuses. How this behaves during filtering is something that will have to be determined.

Assigning to 1.16 so that it's properly considered in conjunction with filters.

Since "CUNY wide" suggests that a course / site / group applies to all of CUNY's campuses, the behavior that the user can't select other campuses is correct.
During filtering of courses (related to #11298 and #11395), if a user selects a single or multiple campus, all courses that have the meta data of "CUNY wide" should appear in the list.

#3 Updated by Boone Gorges about 2 years ago

  • Status changed from Assigned to Resolved

I've made a change to ensure that filtering by a specific campus will also match courses marked 'CUNY wide'.

Based on the above conversation, I think that no further action is required here.

Also available in: Atom PDF