Project

General

Profile

Bug #12

Crob box for avatar images won't expand smoothly

Added by Mikhail Gershovich almost 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
-
Start date:
2009-09-12
Due date:
% Done:

0%

Estimated time:

Description

Crop box for thumbnail and fullsize avatar images won't expand smoothly. Seems to only expand by increments from the bottom left corner of the box.

History

#1 Updated by Matt Gold almost 10 years ago

I doubt that this is something we'll be able to fix, but we can try. It likely has something to do with the Javascript that BuddyPress uses for the image cropping tool. I've seen slight wonkiness in the cropping tool throughout my experience with BP.

Can you give us a little more information about your experience? The following would be helpful:

-- OS
-- Browser
-- Group or Individual avatar
-- Size (dimensions and weight) of photo being added

Thanks. Hit "update" when you come back to this page to add your answers.

#2 Updated by Matt Gold almost 10 years ago

  • Category name set to BuddyPress (misc)
  • Status changed from New to Reporter Feedback

#3 Updated by Matt Gold almost 10 years ago

Hey Mikhail,

When you have a chance, can you try this again and let me know what you find? If you continue to have trouble, please let us know the info in my post above.

Thanks very much for your help.

Matt

#4 Updated by Mikhail Gershovich almost 10 years ago

Still as it was.

Mac OS X 10.6.1
FF 3.5
Group avatar
.jpg 222x223 20k

#5 Updated by Matt Gold almost 10 years ago

Thanks for updating, Mikhail. Can you do me a favor and try these two things:

-- With that same OS/Browser configuration, try uploading a different image file (or, even better, a few different image files)

-- Try uploading that same image with a different browser (perhaps safari).

Let us know how things go.

Thanks in advance for your help -- this testing will help us narrow down where the problem lies.

#6 Updated by Mikhail Gershovich almost 10 years ago

Same problem in Safari 4 with that image and a different one. Will try in Windows later today.

#7 Updated by Mikhail Gershovich almost 10 years ago

Problem recurs in Chrome and IE 8 in XP. Used a .gif this time.

#8 Updated by Matt Gold almost 10 years ago

  • Status changed from Reporter Feedback to Assigned
  • Assignee set to Boone Gorges

Thanks for continuing to experiment with this, Mikhail. I was able to reproduce this error as well; I think it's related to our most recent BuddyPress upgrade (done a few weeks ago).

It looks like problems with the avatar cropper javascript have been popping up with this version of BuddyPress . The good news is that a new version of BuddyPress (1.1) is due to be released in a few weeks.

We have two options right now. We can update the avatar cropper JS from the latest beta build, or we can wait a few weeks for the official 1.1 release. There are risks and problems either way we go, but we'll think about it and get back to you. Thanks again for alerting us to this issue.

As a temporary workaround, we can put up a note about the janky cropper and advise members to crop their own avatars before uploading.

#9 Updated by Boone Gorges almost 10 years ago

  • Status changed from Assigned to 3

I'd rather wait for the BP upgrade, which should hit in the next week or two, than apply a patch. I have added the warning about the buggy cropper, though. It can now be seen on the group and individual avatar upload pages. I'll leave the ticket Resolved but open until we confirm that the upgrade fixes the problem for good. Thanks for your help, Mikhail.

#10 Updated by Boone Gorges almost 10 years ago

  • Status changed from 3 to Resolved

Also available in: Atom PDF