Project

General

Profile

Bug #12185

Group links not working

Added by Matt Gold about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority name:
Immediate
Assignee:
Category name:
-
Target version:
Start date:
2019-12-04
Due date:
% Done:

0%

Estimated time:

Description

Group links appear to be not working/severely misdirecting

for example:

this link, when clicked from the group directory

https://commons.gc.cuny.edu/groups/introduction-to-digital-humanities-2019/

leads here when clicked:

https://commons.gc.cuny.edu/forums/forum/help-2/introduction-to-digital-humanities-2019/

History

#1 Updated by Matt Gold about 2 years ago

Now it seems to be working

#2 Updated by Boone Gorges about 2 years ago

  • Status changed from Assigned to Reporter Feedback
  • Target version set to Not tracked

This is a recurrence of https://redmine.gc.cuny.edu/issues/11665. nextgen-gallery is the culprit. I am putting out other fires and do not have the time to debug the root cause, but the proximate cause is that nextgen-gallery was activated. Do we have any idea why that happened? CCing super admins.

I've deactivated the plugin.

#3 Updated by Matt Gold about 2 years ago

Thanks, Boone. I did not activate/touch nextgen-gallery

#4 Updated by Marilyn Weber about 2 years ago

No clue here.

#5 Updated by Laurie Hurson almost 2 years ago

Hi All,

It occurred to me that nextgen-gallery is included in the multimedia plugin package. Since it is causing these issues, should we consider removing it from the plugin package so it isn't more widely activated than it needs to be, and likely on sites that dont end up using it?

https://help.commons.gc.cuny.edu/plugin-packages/

#6 Updated by Boone Gorges almost 2 years ago

  • Status changed from Reporter Feedback to Resolved
  • Target version changed from Not tracked to 1.16.1

Hi Laurie - The fact that the plugin is in the multimedia package is a good theory that I hadn't thought of. I investigated and found that the main site does not have the other plugins from the package activated, and does not have the bit of metadata that indicates that it's running the multimedia package. So I think this hypothesis is probably not true, and no action is needed here. (The nextgen-gallery problem with BP permalinks only occurs on the main site.)

Out of an abundance of caution, I've added some logic that prevents nextgen-gallery from ever being activated on the main site: https://github.com/cuny-academic-commons/cac/commit/a9e7e6144b3a64dc10604d2aae7f135dce8c601a

Also available in: Atom PDF