Project

General

Profile

Bug #12354

sites (including Net-Art) are reporting critical issues

Added by Marilyn Weber almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority name:
Urgent
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2020-02-02
Due date:
% Done:

0%

Estimated time:

Description

Via Zendesk, three sites (including Net-Art) are reporting critical issues:

I've attached screenshots for two of them.

https://netart.commons.gc.cuny.edu/
https://humanities2020.commons.gc.cuny.edu/
https://2020larsson130.commons.gc.cuny.edu

Hum2020.jpg (27.6 KB) Hum2020.jpg Marilyn Weber, 2020-02-02 10:22 AM
netart problem.jpg (13.8 KB) netart problem.jpg Marilyn Weber, 2020-02-02 02:26 PM
humanities 2020 .jpg (18.3 KB) humanities 2020 .jpg Marilyn Weber, 2020-02-02 02:27 PM
2020 larsson.jpg (18.4 KB) 2020 larsson.jpg Marilyn Weber, 2020-02-02 02:27 PM

Related issues

Related to CUNY Academic Commons - Bug #12363: more bbPress problems - now students unable to post either a new thread or a comment Resolved2020-02-03

History

#1 Updated by Raymond Hoh almost 2 years ago

  • Status changed from New to Reporter Feedback

Hi Marilyn, the Humanities 2020 page in the screenshot seems to be loading now.

Can you tell me if any of the pages on those sites are experiencing problems at the moment? If so, can you list the URLs? I cannot seem to find one.

#2 Updated by Marilyn Weber almost 2 years ago

The problem only appears when I'm logged in - new screenshots attached.

#3 Updated by Marilyn Weber almost 2 years ago

Here are the original zenDesk tickets:

Ryan M. Seslow
Today ‪08:44 am‬

Hi Guys!

Good Morning,

Looks like there is an issue with the Net-Art site.

Seems to be OK on the front end but when I attempt to log in on the

admin side I am getting an error message (see attached).

Any help would be greatly appreciated!

(no rush at all, just wanted to reach out)

Good Energy and many Thanks!

Ryan

site - https://netart.commons.gc.cuny.edu/

Yolande Brener
Today ‪07:09 am‬

My class website has encountered a critical error. I'm not sure whether there is a way to restore it, or whether I will need to rebuild it now. It contained students' submissions for an online assignment that was due tomorrow morning. Please can you advise. I have read the information about debugging but I do not understand it.


Anna Larsson
Yesterday ‪08:34 pm‬

Dear Support,

I have attempted to log in to my course website at https://2020larsson130.commons.gc.cuny.edu. Unfortunately, when I am logged into the Commons I get a message that there is a critical error on the site and a link to Wordpress on debugging. When I am not logged in I can see the site, but I really need to access it and add course readings and so on. Please help.

Thank you,

Alexis Larsson

#5 Updated by Raymond Hoh almost 2 years ago

  • Category name set to WordPress Plugins
  • Status changed from Reporter Feedback to Resolved
  • Assignee set to Raymond Hoh
  • Target version set to 1.16.5

Thanks for the additional details, Marilyn. The issue was caused by the fix implemented to address the forums issue in #12336.

I've pushed a hotfix on production to fix the issue.

Boone, here's the commit:
https://github.com/cuny-academic-commons/cac/commit/437192fc434055dd1a3be4e1240109c212db306b

The fix in #12236 included a check for is_bbpress(), which can only be used after WordPress is initialized. Using this function beforehand throws a fatal error, which is what happened here. I'm not sure how I didn't catch this during my local tests!

I fixed this by checking if WordPress is set up with a did_action( 'wp' ) check. I'll also open a ticket on bbPress Trac so other developers do not run into this problem with is_bbpress() again.

#6 Updated by Marilyn Weber almost 2 years ago

Thanks! I've let them know.

#7 Updated by Raymond Hoh almost 2 years ago

  • Related to Bug #12363: more bbPress problems - now students unable to post either a new thread or a comment added

Also available in: Atom PDF